Modifying spelling in search history item causes loss of subsequent history

RESOLVED DUPLICATE of bug 187410

Status

()

Core
Document Navigation
--
enhancement
RESOLVED DUPLICATE of bug 187410
15 years ago
9 years ago

People

(Reporter: Thomas Hedden, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIXME, DUPEME, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

If you are performing searches with Google and go back in the
session history (using the "Go" button) and modify a previous
search, you lose all history subsequent to the modified search.


Reproducible: Always

Steps to Reproduce:
1. Go to Google http://www.google.com
2. Do several searches, one after the other, to build session history.
3. Click on "Go" menu to display session history: Everything OK, history is there.
4. Go back a couple of searches to a previous search.
5. Click on "Go" again: Everything OK, subsequent history is still there.
6. Now modify the previous search by changing its spelling.
7. Click on "Google Search" or press the Enter key.
8. Click on "Go" again: All history following the modified search is gone.

Actual Results:  
All history following the modified search is gone.

Expected Results:  
I expect that the modified search should go to the
top of the history list (most recent item).

I think what is happening is that the history branches, so it is
impossible to decide which branch to take, and the subsequent history
of both branches is cleared.

The simplest way to fix this is simply to put the modified search
at the top of the history list (most recent item). That is, don't
let the history branch, but put branches sequentially at the end
of the session history.

However, there is another possible fix. Why not have branchable
history? If you go back to a history item and branch off from it,
both branches could be remembered and displayed. Then the
history would be shown branching like the roots of a tree.
If you do this, it might make more sense to have the most
recent items at the bottom rather the top of the list.

Another possibility is for the items in the session history
list to have a collapsible hierarchy (like global history
does) within the menu.

The current branch could be in bold face. You could switch
branches by using some key combination like CTRL-right arrow
and CTRL-left arrow.

Maybe this is too much trouble for what it's worth. But, in
any case you shouldn't lose the subsequent history. At the
very least the modified search should be appended to the
end of the session history.

Updated

14 years ago
Whiteboard: WONTFIXME
I seem to recall the branchable history thing being suggested earlier (but maybe
it's this bug I'm recalling?)

In any case, it could perhaps be done, but some decent UI would need to be
designed first.
Whiteboard: WONTFIXME → WONTFIXME, DUPEME

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 187410 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: chrispetersen → docshell
You need to log in before you can comment on or make changes to this bug.