Status

()

Core
Networking: HTTP
RESOLVED INVALID
15 years ago
4 years ago

People

(Reporter: Ric Steinberger, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

The redirection error limit is still alive!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Reporter, do you mean bug 153888 ? That has been reopened.

Comment 2

15 years ago
Is there a particular URL that is problematic for you?

Comment 3

15 years ago
Got this in email:
"Looks like it had something to do with blocked cookies.  An example URL
is:

http://www.timesonline.co.uk/article/0,,6003-617585,00.html

I was seeing the Redirection error message before I allowed that site to set a
cookie.  Grrrrr.  Not your fault, but annoying/confusing."

Ric, you should be seeing the following error message: "Redirection limit for
this URL exceeded.  Unable to load the requested page.  This may be caused by
cookies that are blocked."

Is this the message you are seeing?  If so, I'm not sure there's too much to
work on here.  Mozilla can't necessarily know why it's in a redirection loop,
and the error message itself is not a problem, just the symptom.
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: asa → httpqa
Summary: Redirection limit error STILL present → Redirection limit error

Comment 4

15 years ago
I'm also getting the 'redirection limit...' error message, at
http://www.nytimes.com/2003/03/30/opinion/30SUN1.html.  Galeon and Konqueror
load the page without error.

To the best of my knowledge, I don't have any cookies blocked ('Enable all
cookies' is checked).

I sent a message using a website feedback link at nytimes.com, hoping that if
the problem is on their end, they'll fix it.

Comment 5

15 years ago
Using the 'cookie manager', I deleted all of my nytimes.com cookies and now I no
longer get the error message.
(Assignee)

Comment 6

15 years ago
dwitte: could this be a duplicate of that cookie parser bug?
Whiteboard: DUPEME

Comment 7

15 years ago
the original bug was reported on 1.3, not sure what to make of that. given the
rewrite, results on a current trunk would be much more useful - reporter: are
you able to test a current trunk build?

Steve: can you specify the following?

a) what build you tested
b) your cookie preferences
c) your cookie javascript preferences

in addition - if you tested on a recent trunk build, then please download
tomorrow's build and test that. there are a couple of fixes in there for some
bugs that may be giving you these problems. thanks!

Comment 8

15 years ago
adding steve to cc: there's a comment here addressed to you.

Comment 9

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040412

The UK Times link in the url does not work and the NY Times link does not
produce a redirection limit error message.

Comment 10

14 years ago
example link is now a 404 -> INVALID

Comment 11

14 years ago
see also bug #211929

Comment 12

13 years ago
Here's a URL that exhibits the problem:

http://msdn.microsoft.com/library/en-us/spptsdk/html/CreateWPToolPart.asp?frame=true
The URl from comment #12 is a server problem, it's a real redirect loop
(also in IE).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.