[DOGFOOD]form submission in bugzilla doesn't work with 11/23 builds

VERIFIED FIXED in M12

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Scott MacGregor, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] 10-Dec-1999)

(Reporter)

Description

18 years ago
Using 11/23 release build, I can't post bugzilla bugs or changes to existing
bugs.

I think it has to do with the post data being lost. I tried to file a new bug
and some fields were posted (like the description). Other fields were not:
assigned to, reporter, etc. Thse all came up as UNKNOWN.

When I tried to modify an existing bug, I got a message about not setting
the product and other fields.

I'm going to start with Eric since he's been helpful in the past with similar
bugs using bugzilla.

Updated

18 years ago
Whiteboard: [PDT+]

Comment 1

18 years ago
Putting on PDT+ radar.
(Assignee)

Comment 2

18 years ago
I've seen a similar bug, but it's number escapes me.  I think the problem might
be that selects aren't submitting a value unless the user does some mystical
action (opening them, but I couldn't reproduce the bug to be sure).

CC'ing rods and kmcclusk
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 10-Dec-1999
(Assignee)

Comment 3

18 years ago
No carwash for me!  :)
(Reporter)

Comment 4

18 years ago
Eric, if it helps at all. Bugzilla worked fine for me with Mondays build. The
regression was definetly introduced Monday.

Also, in testing this bug you probably need to turn gfx scrollbars off. They
just got turned on last night and it broke bugzilla before we get to the form
submission stage. See Bug #19376

Comment 5

18 years ago
I may have just fixed this. It work in viewer now.
(Reporter)

Comment 6

18 years ago
Thanks Rod. I'm pulling your changes now and will try them out. Eric,
you may get your car washed yet =)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
I checked in a fix for form submission last wednesday, so it now works without
gfx scrollbars, marking as fixed.

Updated

18 years ago
Target Milestone: M12

Comment 8

18 years ago
QA Contact update.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Marking VERIFIED FIXED on WinNT 1999120209 mozilla.
You need to log in before you can comment on or make changes to this bug.