http file downloads are incomplete but are reported as finished

RESOLVED DUPLICATE of bug 168846

Status

()

RESOLVED DUPLICATE of bug 168846
16 years ago
15 years ago

People

(Reporter: phireph0x, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

(See bug 182742 for an alternate description of this behavior, on a different OS)
On mozilla 1.3 in Mandrake Linux 9.1, downloads quit early -- before the entire
file transfer has completed.  I'm using the progress dialog, NOT download
manager.  I've tested this on Eclipse 2.1 for Linux GTK2
[http://download.eclipse.org/downloads/drops/R-2.1-200303272130/eclipse-SDK-2.1-linux-gtk.zip]


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.  Type
http://download.eclipse.org/downloads/drops/R-2.1-200303272130/eclipse-SDK-2.1-linux-gtk.zip
in the address bar.
2.  Allow the file to transfer.
3.  Wait for the download to quit early.

Actual Results:  
When I tried it a second time, the download worked fine, but it has failed on
numerous occasions, and on different files.

Expected Results:  
Downloads should completely transfer the requested file.

Using the skypilot theme version 1.9irc for mozilla 1.3+

Comment 1

16 years ago
I see this behavior in Moz 1.3 on W2K SP2.  Multiple attempts of same files get
varying amounts of data (downloading for instance redhat ISOs).  In every case,
download manager shows Completed status and "nKB of nKB" shows that full file
was downloaded.  However, file is not full size.  This also happens using FTP to
download.  So note:

Not just Linux.
Not just HTTP.

Comment 2

16 years ago
I also experience similar problem.  My situation:
Win2K SP3
Build ID: 2003050714

I have use the download manager to download various files and it was shown to be
completed even though it was not (the file size is smaller when I check it using
windows explorer.)  This has happened to various sizes of file (to something as
small as 363KB... that was winima61.zip at http://www.winimage.com/download.htm)

Would this be due to some kind of error in timeout handling?  I am using dial-up
and this usually happen when I try to download multiple things at once.

Comment 3

15 years ago
I am running Mozilla 1.4 on W2K sp2 and see this behavior for large files (e.g.
Knopppix ISO image 727,xxx,xxx bytes).

Specific behavior is 

  - varying amounts of download complete
  - download mgr. always reports normal completion
  - problem is not related to the lack of disk space for temporary file.
  - immediate download by MS IE following the failure was successful
  - when failure occurs, the download stops and the download mgr. starts 
    to copy the temporary file from the tmp location into the target
    directory. After that the link times out and is disconnected by the
    host.

In recreating, I suggest that a large file be used. I have not seen the problem
on small to medium sized files.

Comment 4

15 years ago
i have the same problem with another symptom.

there are several mp3 files i am trying to download from my custom http server.
if i just click on the link for the song, the popup asks if i want to save to
disk. in this case, i say yes and the download is always successful to the byte.
however, if i right-click and say "save link target as..." then the result is
always a file less in size than it should be, but close to it - ie, a k or two
less than what it should be (out of a couple megs). mozilla download manager
reports the download as ok.

my extra symptom is the fact that whenever i save link target as (downloading
these mp3's from my http server using save as), the mozilla download manager
does not know what the file size is as reported by http Content-length: whereas
it always knows the size when i simply click on the link. using msie, regardless
of whether i click on link or save as, the resultant download is always correct.

sounds to me like some kind of connection buffering issue, and possibly the
problem is on the side of my http server, but since others are also having the
same symptoms, and it does not happen with msie, it sounds like it may be a
mozilla issue (i'm using mozilla 1.5 on windows)

Comment 5

15 years ago
->necko http
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: asa → httpqa

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 168846 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.