Input type=submit/button form field CSS font-family style reverts to default, when mouse [hovered over | clicked on] it.

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: jasonpell, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

The 'Add New Item' button (of the attached html file) should not revert to the
default font for form buttons, when the mouse hover's over it.

The problem disappears if I remove the: 
    .menutext:hover { text-decoration: underline; } 
style element.

I am unsure whether this is a correct CSS attribute for a SELECT
object, but the text of the button does actually change to underline,
even when the font is reset.

Reproducible: Always

Steps to Reproduce:
The attached HTML page, is all that is required to reproduce the problem.  Open
the page using a 1.3 copy of mozilla.  (I have not tried on other versions). 
Move the mouse over the 'Add New Item' button.
Actual Results:  
The 'Add New Item' button resizes to the same font as the 'Search' button, even
though the 'Add New Item' is of a different class.

Expected Results:  
The button should have stayed in the font specified for the menutext CSS class.
(Reporter)

Comment 1

16 years ago
Created attachment 118845 [details]
Example of problem - html page.
(Reporter)

Comment 2

16 years ago
Hi,

I should add, that if I remove the 'Search' submit button OR set the input type
to 'button' instead of 'submit' the font problem does not occur.

Thanks
Jason
(Reporter)

Comment 3

16 years ago
Tried it with newer browser version (to comply with 2 week old rule you have),
and still experience the same problem.
(Reporter)

Comment 4

16 years ago
I have looked into it a bit more, and if I remove the:

   .menutext:hover { text-decoration: underline; }

The problem does not occur until I actually click on the button.
(Reporter)

Updated

16 years ago
Summary: Select form field CSS font-family style reverts to default, when mouse hovered over it. → Input type=submit/button form field CSS font-family style reverts to default, when mouse [hovered over | clicked on] it.

Comment 5

16 years ago
CONFIRMing using 1.4a on WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Over to style system.  There is no DOM involved here...

What I see is that when I load the testcase (in a 2003-06-14-05 build) the
left-hand button is the same as the right-hand one, but uses a Verdana font. 
Hovering it makes the font bigger (bold actually!) and that persists when I
unhover it.  The font-family remains Verdana, however.
Assignee: jst → dbaron
Component: DOM Style → Style System
Oh, same result in a 2003-06-19-05 build.

Comment 8

14 years ago
*** Bug 262356 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Still a problem in the Firefox nightlies up to 20041013...

Problem happens when a button is a different font also. When the button is
clicked, it reverts to the default 10pt Arial one.

Comment 10

13 years ago
see also bug 274337
Following the landing of bug 377947, we're consistent about ignoring the specified font-family.  But that doesn't seem right either, given the style rules and the computed style on the input, although DOM inspect doesn't let me look at the stuff inside the input.
The remainder of the problem is fixed by the patch in bug 216456.
Assignee: nobody → dbaron
Fixed on trunk by checkin of bug 216456.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.