Incoming junk mail is not filtered properly

RESOLVED WORKSFORME

Status

MailNews Core
Filters
--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Chaminda, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

Incoming junk mail filtering not working.

Reproducible: Always

Steps to Reproduce:
Here are steps I did to configure the junk mail contols.
1.Tools->Junk Mail controls
2.Selected the mail account from dorpdown menu
3.check the "Enable junk mail controls"
4.Check the "Incoming mail is not filtered properly" and selected the contacts.
Actual Results:  
All the junk mail is still coming to my inbox. Not a single junk mail was ditected.

Expected Results:  
I would expected all incoming mail to filterd accourding to the my list of
contacts(email addresses).

Comment 1

15 years ago
Possible dupe of bug 194238.
Reporter, do you still see this with a trunk build dated 20030324 or newer,
where 194238 was fixed?

Comment 2

15 years ago
Reporter (Chaminda): Please report whether this bug is still a problem for you, 
using a more up-to-date version of Mozilla (1.5 preferred, or 1.4 if necessary).

Comment 3

15 years ago
Junk mail filtering stopped working in Moz v1.4 with multiple IMAP accounts. It
had been working quite well for the last week. I decided to run the Junk Mail
Filters against a folder that had nothing but several thousand already filtered
junk emails with the idea of 'training' the junk mail filter. After filtering
about 1000 messages (out of 8000) I got a dialog box with an error message
saying the the 'Command to the mail server was too long...' and the junk mail
filtering stopped.

I quit and re-started Moz v1.4 and tried the same folder again using the
Tools->Run Junk Mail Controls on Folder. This time nothing happened. I gave up
troubleshooting at that time. Later I discovered that the Junk Mail controls
were no longer enabled. I re-checked the 'Enable Junk mail controls'. I also
quit and restarted Mozilla.

Since that event however, none of the junk emails coming into my IMAP inboxes on
2 accounts are being flagged as junk. When I run Tools->Run Junk Mail Controls
on Folder, nothing gets flagged as junk although, I do see a message on thelower
status bar saying: 'Downloading messages...' I also observe high CPU utilization
for a few seconds. However, no messages are flagged as junk.

I decided to upgrade to Moz v1.5 (Mozilla/5.0 (X11; U; SunOS sun4u; en-US;
rv:1.5) Gecko/20031018). The exact same thing happens - nothing is flagged as
junk and when running it manually although I see 'Downloading messages...' and
high CPU usage, none of the spam messages in my Inbox (or any other folder) gets
marked as Junk.

I suspect that the Junk Mail database that stores 'learned' information has
become corrupted and now, although junk mail filtering is occuring - no messages
are every flagged as junk due to a corrupted junk mail database. I believe that
if I wipe out the junk mail database and let it start re-learning again that it
will likely continue working. It is quite possible that the junk mail
controls/database simply can't handle a huge volume of junk email. I typically
receive over 2000 (yes, thats 2 followed by 3 zeros) spam messages per day. Most
if that junk is pre-filtered and filed using a conventional Mail Filter.
However, some junk gets thru to my inbox (about 100 or so every day) and I was
just starting to use the built in junk mail controls as a last line of defense.

The Junk email controls are promising however - not having any access and/or
control of what is 'learned' is a significant disadvantage.

Comment 4

15 years ago
Bob Atkins, it is possible you have encountered bug 192119 or bug 213300.  (The 
latter has some discussion of how some antivirus software can interfere with the 
junk processing.)

Comment 5

15 years ago
After reading bug 192119 and bug 213300 I can confirm that neither of those bugs
is playing a role in the problem that I am reporting here. I am running on
Sun/Solaris and I am not using a virus filtering program that intercepts the
incoming email.

I have confirmed that after deleting the junk 'knowledge' database (traning.dat)
and restarting mozilla that junk mail filtering starts working again. Over time
I have noticed that the effectiveness of the junk filtering falls off. I have
also avoided allowing the junk filtering to run against my 'Junk' folder or any
other folder where I store purely junk email. Before selecting one of those
folders I have to go through the trouble of turning off the Junk email controls.

I had found a couple of other bugs (now I can't find them) that seemed to relate
to the problem that I am reporting here.

I believe that the Junk filtering function needs to allow for certain folders to
be listed as 'ignore/do not evaluate'. It is a major hassle to have email in my
Sent or Drafts folder flagged as junk (for what reasons I do not know). If I
select one of the folders that I keep spam in - Mozilla will all but lock up
while it examines all of the stuff (usually several thousands) that I already
know is junk. Such a case of over training seems to kill the effectiveness of
the Junk email knowledge database and after attempting to evaluate all of the
email in any folder that only contains spam I need to delete the training
database and let thing s start fresh in order to get any Junk filtering to work
in the Inbox.

Comment 6

15 years ago
Bob Atkins: See:
  bug 200087: Junk classification effectiveness peaks and then falls over time
and
  bug 196964: Add folder properties to allow user to disable automatic junk mail 
              analysis on a per folder basis

Chaminda, still waiting for a status update from you.

Comment 7

14 years ago
No response from reporter(s).   =>WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.