Crash trying to log help desk ticket

VERIFIED FIXED in M13

Status

()

P1
critical
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: scalkins, Assigned: harishd)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Build 1999-11-23-09 M12
Steps to Repro:
1)Go to the URL :
http://request/helpdesk/secureid_sera_preprocess.cgi
(You may be prompted to login at this secure site)
2)When you get to the page, click on the button labeled "Continue"

Actual results: The page starts to draw, but you will get a crash and exit
seamonkey.

Expected results: You are taken to the page :
http://request/helpdesk/secureid_sera.cgi?user= <your login name here>

Notes:Works ok in Netscape 4.7.1

Talkback trace follows:
Incident ID 1341220
 Trigger Time
               1999-11-23 15:12:42
 Email Address
               scalkins@netscape.com
 User Comments
               crash clicking continue at this site
 Build ID
               1999112217
 Product ID
               Communicator5.0
 Platform ID
               Win32
 Stack Trace

CNavDTD::IntTagToStringTag
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1972]
CNavDTD::WillHandleStartTag
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1117]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1298]
CNavDTD::DidHandleStartTag
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 846]
CNavDTD::HandleEntityToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1676]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1266]
GetIndexOfChildOrSynonym
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 870]
CNavDTD::HandleEndToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 1507]
CNavDTD::DidHandleStartTag
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 846]
CNavDTD::DidBuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 580]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1250]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1030]
detectByteOrderMark [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1183]
nsFrameImageLoader::NotifyError
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameImageLoader.cpp, line 477]
(Reporter)

Updated

19 years ago
Priority: P3 → P1

Comment 1

19 years ago
gerardo - can you assign to the proper engineer?

Updated

19 years ago
Assignee: leger → karnaze
Component: Browser-General → Form Submission
QA Contact: leger → cpratt

Comment 2

19 years ago
Setting QA Contact and component.

Updated

19 years ago
Assignee: karnaze → harishd

Comment 3

19 years ago
Reassigning to Harish.

Updated

19 years ago
Assignee: harishd → petersen

Comment 4

19 years ago
I can't reproduce this. The console gets an error that read "Can't load: (url)".
Chris -- can you get me a reproduceable case?

Comment 5

19 years ago
QA Contact update.

Updated

19 years ago
Assignee: petersen → rickg

Comment 6

19 years ago
Rick, I can't get the application to crash based on the steps provided. Maybe we
need to have the reporter recheck the steps to this bug.

Updated

19 years ago
Assignee: rickg → scalkins

Comment 7

19 years ago
Scalkins: Please recheck this problem. If possible, please provide a new recipe
that we can follow to reproduce this.
(Reporter)

Comment 8

19 years ago
with build 1999-12-15-17 M12, I don't crash when I click on Continue
(Though it does not go to the url is supposed to go to)...but if I put the
following URL where it should have gone in the URL bar it will crash when I hit
the enter key:
http://request/helpdesk/secureid_sera.cgi?user=scalkins
(Reporter)

Comment 9

19 years ago
Stack trace from that crash is below:
Incident ID 2581982
 Trigger Time
               1999-12-16 12:17:22
 Email Address
               scalkins@netscape.com
 User Comments
               Crash attempting to go top helpdesk URL
http://request/helpdesk/secureid_sera.cgi?user=scalkins Win build 1999-12-15-17
M12
 Build ID
               1999121516
 Product ID
               Communicator5.0
 Platform ID
               Win32
 Stack Trace

0x00000003
CNavDTD::WillHandleStartTag
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1080]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1286]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 764]
CNavDTD::HandleSavedTokens
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1641]
CNavDTD::HandleOmittedTag
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1243]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 987]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1350]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 764]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 528]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1044]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 968]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1328]
nsDocumentBindInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1456]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 218]
nsChannelListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1604]
nsHTTPResponseListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 202]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
370]
nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
94]
PL_HandleEvent [plevent.c, line 523]
_md_EventReceiverProc [plevent.c, line 951]
USER32.dll + 0x1820 (0x77e71820)
(Reporter)

Updated

19 years ago
Assignee: scalkins → karnaze
(Reporter)

Comment 10

19 years ago
Changing bug owner to default for selected component

Updated

19 years ago
Assignee: karnaze → harishd

Comment 11

19 years ago
Reassigning to Harish.

Comment 12

19 years ago
harish -- I can't reproduce the original bug, nor can I reproduce the bug cited
for the url http://request/helpdesk/secureid_sera.cgi?user=scalkins. We may want
to ask the reporter to resubmit with another test case that we can verify.
(Assignee)

Comment 13

19 years ago
Created attachment 4117 [details]
A test case that would crash.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

19 years ago
Fixed by handling the misplaced ( in TABLE ) TEXTAREA.

Comment 15

19 years ago
Marking VERIFIED FIXED on:
Win98 2000-01-24-00 mozilla build
Linux6 2000-01-24-01 commercial build
MacOS86 2000-01-24-02 commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.