USPS (United States Post Office) shop cannot be accessed - cannot buy stamps

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Tom Schneider, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212

The USPS sells stamps on line but if one tries to go to the page
using Mozilla one always gets an error message.

Reproducible: Always

Steps to Reproduce:
1.go to http://www.usps.com/all/welcome.htm
2.then Stamps (Buy Online)
Actual Results:  
It goes to
http://www.usps.com/all/shop
which redirects to:
http://shop.usps.com/cgi-bin/vsbv/postal_store_non_ssl/customer_care/browserPreferences.html
this is an error page.  For the record, it is
---------
 Problems with accessing the page?

If you have been redirected to this page, your browser settings need to be
altered. These are usually found under the "Options" Menu. They are very easy to
change.

    *

      Check the setting for your browser's ability to accept cookies (found
under Advanced or Security). If you would like to view the cookies before they
are placed on your browser please choose the "Prompt before Accepting" option,
but in order to view this site, cookies must be enabled.
          o

            Internet Explorer 5
            1. Click the Tools, and then click Internet Options.
            2. Click the Security tab.
            3. Click the Internet zone.
            4. Click Custom Level, scroll to the Cookies section, an then click
Enable for both cookie options.
          o

            Internet Explorer 4.x
            1. Click the View, and then click Internet Options.
            2. Click the Advanced tab.
            3. Scroll to the Security section.
            4. Under Cookies, click Always accept cookies.
          o

            Netscape 4.0 and higher
            1. Click on the Edit mean and click Preferences.
            2. Click the Advanced Settings on the bottom of the dialog box.
            3. Choose the following options: Accept all cookies.
    *

      Check the setting for your browser's "cache" (found under "Network
Preferences"). Allocate as much space on your hard drive as you can afford. Have
your computer check the cache every time (as opposed to once per session or
never) to guarantee that you are seeing the latest web content.

    *

      Make sure Javascript is enabled under "Languages" in "Network
Preferences." Javascript is used extensively throughout The Postal Store, and
enabling it will aid your enjoyment immensely.

    *

      And finally, be sure to make http://www.usps.com/shop your home page!

---------

Expected Results:  
I should have gotten into the stamp buying web pages.

This may be related to Bug 107475.
I am marking this a Major because it means that Mozilla users in
the USA cannot buy stamps on line!!

I reported this problem to USPS and got this response:

Dear USPS Customer,
Thank you for contacting us. We are glad to hear that you have a system that
is very up to date. the problem is that the website is designed for use with
Netscape or IE.  The website  also does not work well with the MAC OS. If
you want to us the site please make sure that what ever browser you are
using has 128bit encryption. Since you do not like Microsoft you should give
Netscape a try. Even if Mozilla is more advanced, Netscape can still handle
the job. 

USPS Internet Customer Care Center
icustomercare@usps.com
------
This was AFTER asking them to fix it.  It may be something that only
they can fix.

Comment 1

15 years ago
wfm winxp 2003302810 trunk.

I see you're using Mozilla 1.3 alpha, can you try with Mozilla 1.3 to see if it
is still a problem ?

Comment 2

15 years ago
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130

I know I'm using an old and outdated build (and a non-supported OS), but if I go
to http://www.usps.com/all/shop i end up in a page that tells me  "File or Page
Requested Not Found"

Following the link at "buy stamps and shop" in the left upper corner at
http://www.usps.com/all/welcome.htm takes me to http://www.usps.com/buy/welcome.htm

From there everything seems to work OK.

Comment 3

15 years ago
WorksForMe using FizzillaMach/2003032808. Tom, are you absolutely certain you
don't have any cookies blocked from that site? Try testing using a new Mozilla
user profile.
(Reporter)

Comment 4

15 years ago
Sorry for the delay, I was on a trip.  Yesterday I upgraded to:

Mozilla 1.4a
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401

I tried accessing the site again and got the same problem.

I looked into my cookies and found:

shop.usps.com       site can set cookies

So it's still a problem on my system. 

------

Following Comment #2 from Stefan,
I also get to http://www.usps.com/buy/welcome.htm   
but if I click on
"Buy Stamps Online Now!"   

I get the same error page as before.
(Reporter)

Comment 5

15 years ago
I created a new user profile and that worked.

Then I went back to my original profile and found that
I had blocked cookies.  So I added http://www.usps.com/
which shows up as www.usps.com on the list of allowed
popups.  This did not help.

I then allowed popups, quit and restarted mozilla
and it STILL does not help.

So some setting in my profile is not allowing access.
What that is is not obvious and so there is a user help
bug at minimum on this one.

(That is, one can't figure out what's wrong by oneself.)

Comment 6

15 years ago
Tom, since it sounds like Mozilla works fine at the site using a new profile,
there probably isn't a Mozilla bug, here.

There must be some setting somewhere that's blocking the cookies for that site.
You'll just need to keep looking until you find it.

Resolving this bug WFM per comment 5. Tom, if you do manage to find some actual
bug, please file a new bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

15 years ago
Greg:

I don't have any Stored Cookes for shop.usps.com or www.usps.com.
www.usp.com was set not to allow cookies.

I removed that.  It did not help.  Do I need to restart mozilla
to make this work?  It's very confusing.  

I removed all cookie sites, a rather drastic measure.

That failed.

I restarted Mozilla.  It still failed.

I removed all cookies, also a rather drastic measure (but
I don't care as much).

That failed.

I now have no cookies and no sites set.  Now you tell me where to        
look!!!

Getting desperate, I cleared my cache and restarted mozilla.

It failed again!!

I had allowed popups - I remove the allowal.

It failed.

Since I can't locate the place THAT IS A BUG!!

I'm stuck.  Please tell me what to do next.

From my viewpoint this bug is not resolved.  I do NOT want to have to
wipe my entire user profile out every time some silly site has trouble
with cookies!  That will be enough for me to abandon Mozilla.
(Reporter)

Comment 8

15 years ago
I am now having trouble with access to
http://www.washingtonpost.com/wp-dyn/articles/A34859-2003Apr24.html
I wiped out ALL cookies and I cleared ALL cookie sites.
It still objected that I didn't have cookies in netscape.
I then allowed cookies from this site and it STILL DID NOT.

When I switch profiles, I got in.

There is a SERIOUS PROBLEM HERE.  Something about the state of Mozilla
IS NOT ACCESSABLE.  That is a BUG.  Please do not expect me to "find"
it - I have done all the obvious things.

Switching profiles is NOT acceptable because all my Moz settings,
and my bookmarks are not in the other profile.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.