Unprofessional error message when download fails

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: oded, Assigned: mcsmurf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

When a download fails for some specific reason (which I could not successfully
reproduce), an error message is displayed to the user. That error message says
that the download failed for some reason, adding the comforting phrase "Sorry
for that."
It looks somewhat unprofessional, much like a screen taken from the "Interface
Hall of Shame" website (e.g., "You shouldn't be seeing this, idiot.")
It should be quite easy to spot the exact location of this message by looking up
this string (or its i18n-ready equivalent) throughout the Mozilla code.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Mozilla should instead display a boring, professionally-phrased error message.
(Reporter)

Comment 2

16 years ago
Yeah, I probably misquoted the error message. Sorry about that..

Comment 3

16 years ago
On the contary, the one time I actually remember seeing this error message, I
was struck by how much *better* it was than most error messages. If mozilla
really has no way of knowing why something went wrong (e.g. because the OS
returns a non-specific error code), I would rather have the application
apologise for being unhelpful rather than just say "An unknown error occured"
before failing - the approach that most programs take. The politeness seems in
contrast to the 'Hall of Shame' example you give, which is bad because it abuses
the user.

If, on the other hand, there is a way of more specifically determining the
problem, then obviously that information should be communicated in the error
message.

Comment 4

16 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 5

16 years ago
*** Bug 209835 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 254788 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

15 years ago
Created attachment 155501 [details] [diff] [review]
Patch
Assignee: firefox → mcsmurf
Status: NEW → ASSIGNED
(Assignee)

Comment 9

15 years ago
Comment on attachment 155501 [details] [diff] [review]
Patch

simple patch to review, three words get removed.
Attachment #155501 - Flags: superreview?(bzbarsky)
Comment on attachment 155501 [details] [diff] [review]
Patch

Sure.  sr=me
Attachment #155501 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Comment 11

15 years ago
Has been checked in:
08/08/2004 14:12	timeless%mozdev.org 	mozilla/ embedding/ components/
webbrowserpersist/ locale/ en-US/ nsWebBrowserPersist.properties 	1.5 	2/2  	Bug
199804 Unprofessional error message when download fails
patch by mcsmurf%gmx.de r=biesi sr=bz
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.