Comment string requires blank char.

RESOLVED INVALID

Status

()

Core
HTML: Parser
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: aynilove [So, Jae-yoon], Assigned: harishd)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030327 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030327 Phoenix/0.5

general commemt format is : <!-- comment -->
however there is someone who use this comment as : <!--comment-->

but mozilla's HTML parser requres at least a blank between "start marker" and
"terminal marker", so (<!--comment--> text... text <!--comment-->)will be
treated as one large comment. (source viewer is useful to guess this problem.)

Reproducible: Always

Steps to Reproduce:
here's example:

<!--1.0@bugzilla.org-->
 
<table border="0">

  <tr>
    <td bgcolor="#000000" valign="top">
      <table border="0" cellpadding="10" cellspacing="0" width="100%"
             bgcolor="lightyellow">
        <tr>
          <td>
<!--1.0@bugzilla.org-->

.. can you see the table?

Comment 1

15 years ago
This WFM in both standards and quirks mode, 2003032808 PC/WinXP

If you have a URL of a page where you can reproduce this problem, or a testcase
that reproduces this problem, that would be helpful.
(Reporter)

Comment 2

15 years ago
It's so strange, I tried to reproduce this error and failed, but hardly find a page.
http://www.o-shohousen.com/

Comment 3

15 years ago
Porn link.  :/

I looked at the source for the front page of that site.  Two comments
matched the description, consisting of a bunch of glyphs (Kanji?) that were
butted up against the dashes:   <!--[Kanji]-->

The first is immediately followed by a more-or-less well-formed <style> element 
(in the <body>, so misplaced); the <style> itself contains superfluous
comment delimiters (as is typical for protecting old browsers against
Javascript).

So, if a Kanji comment flush against the dashes *were* causing a problem, this
page wouldn't manifest it because the thing being commented out wouldn't
be processed anyway.

The content between the Kanji comments was apparently being rendered; the 
'href' values in the <a> links in the source corresponded to the text showing
up on the status bar when I hovered over the racy images in the second large
box from the bottom.

I don't have a Unicode HTML editor, so I can't test this further.

Comment 4

15 years ago
Oh, I *do* have Unicode HTML editor:  Composer.

I copied one of those Kanji comments from the source page, pasted a pair of them 
into the Composer HTML, and verified that the HTML between the pair was not 
treated as comment.  So, it works for me.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030408

Comment 5

15 years ago
Jae-yoon So, if you find a URL that exhibits this problem, please feel free to 
reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.