Automagically replicating mail when mailbox size reaches approx 250 emails

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: dcg, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When the no of emails in 1 of the mailboxes reaches the 250-260 range it looks
like a process of automatic email-replication takes place.
It looks like an arbitrary number of mails get a new reference (as in pointer)
which gives the impression to the mailcounter and the user that the toal number
of mails has gone up.
I mention pointer because on deletion of a number of these duplicate mails ALL
'sister' mails are deleted with it (typical behavior for pointers losing their
object of reference).
I appreciated the 'vage' nature of the behavior. However it is already the
second time. The remedy for the first was copying the whole box re-opening it an
killing a lot of mails. Things were fine until I hit the 250-260 range again.
Then the replicating started. On startup of the app the replication takes place.
During the sessing the sandbox appears whilst hovering over the mail-area.
Using the Norton virus-scanner (thus ruling out virusses) on top of MailWasher.
Thus ensuring that only known mails are retrieved and scanned.
The offending mailbox is used for receiving mail on a developers list so 'weird'
mails are pretty much excluded.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.




It reproduced itself.
Second time was exactly the same as the first time

Comment 1

15 years ago
Mozilla 1.4.1 (or 1.4.2), Windows xp

The same thing has also happened, that e-mails automagically replicate. This has 
also happened after a few reinstalls of the abovementioned version of Mozilla.

A few other problems in Mozilla that might also have had a hand in this:

* e-mails becoming 'Unread' again after being imported from Outlook Express 6.

* The Mozilla ActiveX control (I wanted to use it with launch.yahoo.com), which 
I couldn't remove automatically.
* Then I installed Mnenhy, which is some kind of an external component with 
which I hoped to automatically remove the Mozilla ActiveX control. After trying 
it out, it didn't work. I removed the Mozilla ActiveX control then manually.
* Then things started not working, because e-mails were somehow "lost" — I found 
these agin after setting the e-mail account directories right.
* Then I uninstalled Mozilla 1.4.1, downloaded Mozilla 1.4.2 and installed it 
and after that e-mails started replicating.
* After that, I discovered that while in one Windows xp (admin) profile the 
Mozilla UserAgent was 1.4.2, but in a limited user profile, the Mozilla 
UserAgent was 1.4.1 and showed that Mnenhy was also installed (I think I had 
attempted removing it, but I can't remember... :/ )
* Then I uninstalled that version of Mozilla and reinstalled it from a local 
full install, which I think I downloaded separately and then things seemed to 
work normally.

Could there be a problem with leaving e-mails on the server after downloading 
them and then after uninstall/install with Mozilla Mail downloading them again?

Or Mozilla reading the same profile in again and replicating e-mails or Mozilla 
somehow getting a grasp on profiles placed in backup locations on the same hard 
drive?

Filing of this comment was "inspired" of my first sister's hysterious rant, in 
which she was mentally disabled to tell exactly what happened then-and-then and 
how and after what was done (inability to file a "comprehensive bug report").
(Assignee)

Comment 2

15 years ago
please try  1.7 - most of these issues have been addressed, I believe.
(Assignee)

Comment 3

15 years ago
resolving wfm 1.3 is a very old build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.