Closed Bug 19986 Opened 20 years ago Closed 20 years ago

[CRASH] DHTML / JavaScript Errors?

Categories

(Core :: Layout, defect, P3, major)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: skennedy, Assigned: vidur)

References

()

Details

(Whiteboard: unable to reproduce in 11/30 Commercial on WinNT 4.0 SP3)

Rollovers on homepage do not work. Layer system is used.

Browser crashes when trying to go beyond the homepage.

Any assistance in code used, please let me know.

Scott Kennedy
Webmaster - Send.com
Looks like you're using document.layers, which Mozilla does not support.  See
"http://sites.netscape.net/ekrock/standards.html".

It shouldn't crash though.  If you could reduce the page down to as small as
possible while still preserving the problem, your problem could probably be
resolved quicker, either fixed or as a duplicate of another problem.
Assignee: leger → troy
Component: Browser-General → Layout
QA Contact: leger → petersen
rickg, who should get this one?
Assignee: troy → ekrock
Assignee: ekrock → vidur
Summary: DHTML / JavaScript Errors? → [CRASH] DHTML / JavaScript Errors?
Whiteboard: unable to reproduce in 11/30 Commercial on WinNT 4.0 SP3
As Matty said, it's spec for the page not to work since it uses
document.all/document.layers and must be upgraded per the referenced doc.

On the other hand, the page shouldn't crash even if it uses unsupported
JavaScript.  Scott, I tried to reproduce the crash on WinNT 4.0 SP3 using the
internal 11/30 Commercial build and it didn't crash.  The crash bug may have
been fixed. Could you please download a recent nightly build from
http://www.mozilla.org/binaries.html and see if you still see a crash? If not,
the crash must have been fixed, so please close the bug as INVALID. Thanks!

Reassigning to vidur in the meantime and marking CRASH
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Doesn't crash for me either with the latets build. I'm also running on NT
Status: RESOLVED → VERIFIED
With the Dec 09 th build (1999120910), I can't reproduce the crash mentioned.
Since layers related issue, I will be marking as invalid. If the reporter can
reproduce the crash will simplfied test case, please submit a new bug.
You need to log in before you can comment on or make changes to this bug.