[CRASH] DHTML / JavaScript Errors?

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: skennedy, Assigned: vidur)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: unable to reproduce in 11/30 Commercial on WinNT 4.0 SP3, URL)

(Reporter)

Description

19 years ago
Rollovers on homepage do not work. Layer system is used.

Browser crashes when trying to go beyond the homepage.

Any assistance in code used, please let me know.

Scott Kennedy
Webmaster - Send.com
Looks like you're using document.layers, which Mozilla does not support.  See
"http://sites.netscape.net/ekrock/standards.html".

It shouldn't crash though.  If you could reduce the page down to as small as
possible while still preserving the problem, your problem could probably be
resolved quicker, either fixed or as a duplicate of another problem.

Updated

19 years ago
Assignee: leger → troy
Component: Browser-General → Layout
QA Contact: leger → petersen

Comment 2

19 years ago
rickg, who should get this one?

Updated

19 years ago
Assignee: troy → ekrock
Assignee: ekrock → vidur
Summary: DHTML / JavaScript Errors? → [CRASH] DHTML / JavaScript Errors?
Whiteboard: unable to reproduce in 11/30 Commercial on WinNT 4.0 SP3
As Matty said, it's spec for the page not to work since it uses
document.all/document.layers and must be upgraded per the referenced doc.

On the other hand, the page shouldn't crash even if it uses unsupported
JavaScript.  Scott, I tried to reproduce the crash on WinNT 4.0 SP3 using the
internal 11/30 Commercial build and it didn't crash.  The crash bug may have
been fixed. Could you please download a recent nightly build from
http://www.mozilla.org/binaries.html and see if you still see a crash? If not,
the crash must have been fixed, so please close the bug as INVALID. Thanks!

Reassigning to vidur in the meantime and marking CRASH

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 4

19 years ago
Doesn't crash for me either with the latets build. I'm also running on NT

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
With the Dec 09 th build (1999120910), I can't reproduce the crash mentioned.
Since layers related issue, I will be marking as invalid. If the reporter can
reproduce the crash will simplfied test case, please submit a new bug.
You need to log in before you can comment on or make changes to this bug.