Clicking anywhere in the menu reload the homepage instead of the wanted link

RESOLVED DUPLICATE of bug 199768

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 199768
15 years ago
13 years ago

People

(Reporter: jdelbos, Assigned: asa)

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030329
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030329

Clicking anywhere in the menu reload the homepage instead of the wanted link.


Reproducible: Always

Steps to Reproduce:
1. go to http://www.planetemu.net/
2. try to click any link in the menus (up and left)


Actual Results:  
reloads the index of the site (http://www.planetemu.net/)

Expected Results:  
open the link with a new menu available
working in IE6

Comment 1

15 years ago
I can confirm it with 2003032701 CVS build, but it does not happen with Mozilla
1.3. (both Win2k)
-> related to bug 199768? 

Comment 2

15 years ago
*** Bug 199892 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Ok, this regressed in the same timeframe as bug 199768 (2003032510 to 2003032604).
Confirming, but this is most probably a dup.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 4

15 years ago
view-source:http://www.planetemu.net/headfoot/haut.txt

that document is included in most subpages on the site and indeed checks
document.referrer...

document.writeln('if (document.referrer.indexOf(\'www.planetemu.net\') !=-1)');
document.writeln('{');
document.writeln('}');
document.writeln('else');
document.writeln('{');
document.writeln('if (document.referrer.indexOf(\'planetemu.net\') !=-1)');
document.writeln('{');
document.writeln('}');
document.writeln('else');
document.writeln('{');
document.writeln('if (document.referrer.indexOf(\'planetemu.2xmoinscher.com\')
!=-1)');
document.writeln('{');
document.writeln('}');
document.writeln('else');
document.writeln('{');
document.writeln('document.location.href = \'http://www.planetemu.net\';')


Marking dupe

*** This bug has been marked as a duplicate of 199768 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.