The default bug view has changed. See this FAQ.

Solaris 8 Mozilla removes spaces for text within <font face="Arial">...</font>

RESOLVED DUPLICATE of bug 191335

Status

Core Graveyard
Printing: Xprint
--
major
RESOLVED DUPLICATE of bug 191335
14 years ago
9 years ago

People

(Reporter: Daniela Hoffmann, Assigned: Masaki Katakai)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bug in Solaris /usr/openwin/bin/Xprt])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030307
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030307

Solaris 8 Mozilla removes all spaces for text within <font
face="Arial">...</font> HTML tags.
Replacing "Arial" with "Courier" or "Helvetica" does not cause problems.

Reproducible: Always

Steps to Reproduce:
1. write a test page which uses "Arial":
<html>
<font face="Arial">
ein kleiner test um zu zeigen das hier etwas fürchterlich schief läuft
</font>
</html>
2. print page
Actual Results:  
the page show the text without spaces:
einkleinertestumzuzeigendashieretwasfürchterlichschiefläuft

Expected Results:  
the page should show the text with spaces:
ein kleiner test um zu zeigen das hier etwas fürchterlich schief läuft

analysis:
the bug seems to be related to the Monotype(TM) Arial fonts in
/usr/openwin/lib/X11/fonts/TrueType/, removing the following entries from
/usr/openwin/lib/X11/fonts/TrueType/fonts.dir and restarting the print server
makes the problem go away:
Arial.ttf -monotype-arial-regular-r-normal--0-0-0-0-p-0-iso8859-1
Arial-Bold.ttf -monotype-arial-bold-r-normal--0-0-0-0-p-0-iso8859-1
Arial-BoldItalic.ttf -monotype-arial-bold-i-normal--0-0-0-0-p-0-iso8859-1
Arial-Italic.ttf -monotype-arial-regular-i-normal--0-0-0-0-p-0-iso8859-1
ArialNarrow-BoldItalic.ttf -monotype-arial-bold-i-narrow--0-0-0-0-p-0-iso8859-1
ArialNarrow-Bold.ttf -monotype-arial-bold-r-narrow--0-0-0-0-p-0-iso8859-1
ArialNarrow-Italic.ttf -monotype-arial-regular-i-narrow--0-0-0-0-p-0-iso8859-1
ArialNarrow.ttf -monotype-arial-regular-r-narrow--0-0-0-0-p-0-iso8859-1

Comment 1

14 years ago
is this solaris 8 sparc or solaris 8 intel?
Assignee: asa → font
Severity: blocker → major
Component: Browser-General → Layout: Fonts and Text
OS: other → Solaris
QA Contact: asa → ian
Hardware: PC → Sun
Sounds like a problem with a particular font...

Comment 3

14 years ago
Daniela Hoffmann:
I guess you are _printing_ on Solaris, right ?

If "yes" then this is the same issue as described in 
http://xprint.mozdev.org/bugs/show_bug.cgi?id=3353 ("Solaris Xprt looses space
when rendering with '-monotype-arial-*'-fonts" (=Solaris Xprt is screwed up) ...
;-((

Over to "Printing: Xprint", someone has to file a customer support request at
Sun (http://xprint.mozdev.org/bugs/show_bug.cgi?id=3353 has techincal details
and a reduced testcase for this issue) ...
Assignee: font → katakai
Severity: major → blocker
Status: UNCONFIRMED → NEW
Component: Layout: Fonts and Text → Printing: Xprint
Ever confirmed: true
QA Contact: ian → Roland.Mainz

Comment 4

14 years ago
*** Bug 199963 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Whiteboard: [bug in Solaris /usr/openwin/bin/Xprt]

Comment 5

14 years ago
Boris Zbarsky wrote:
> Sounds like a problem with a particular font.

Yeah, looks that newer versions of the Solaris Xprt now does not like the
monotype fonts anymore... ;-/

Comment 6

14 years ago
Adding
-- snip --
user_pref("print.xprint.font.rejectfontpattern",
"fname=-dt-.*;scalable=.*;outline_scaled=false;xdisplay=.*;xdpy=.*;ydpy=.*;xdevice=.*|"
+
"fname=-monotype-arial.*;scalable=.*;outline_scaled=.*;xdisplay=.*;xdpy=.*;ydpy=.*;xdevice=.*");
-- snip --
to prefs.js works around the problem, however this is no solution since this ban
kills nearly all Arial fonts provided by Solaris.

IMHO a fix can only be provided by the maintainers of the Solaris
/usr/openwin/bin/Xprt ----> Sun ...

Comment 7

14 years ago
Does the about:buildconfig page use Arial fonts?
What about this page
http://www.btinternet.com/~g.a.patterson/mfaq/m_faq-mamiya.html ?
Both show the missing spaces problem when printed? See attachment in bug#199963.
I don't see an Arial font being used there.

Can you point me to a page that should print fine with the Solaris 8 version of
Xprt so I can at least get my XpConfig files correct?

Right now I cannot use the Solaris builds newer than 1.3b. Xprint has no spaces,
and the PostScript module is disabled. I'm, trying to build a nightly with the
PS module, but no luck so far.

I'll try the user pref change. Is that one line?

Comment 8

14 years ago
Thomas Dodd wrote:
[snip - I'll look at the other issues listed in your comment when I am back in
my office...]
> I'll try the user pref change. Is that one line?

Yes, it's one line (but you can split it at the '+'-char, following the
JavaScript syntax for string concatenation (prefs.js is javascript and all the
evil stuff is allowed in there... =:-))

----

Alternate workaround is not to use the Solaris Xprt.
For Solaris there is the "GISWxprint" package which is identical to the
"GISWxprintglue" package except that it uses a Xprt server binary build from
xprint.mozdev.org sources instead of using the Xprt provided with Solaris (see
http://xprint.mozdev.org/download.html ; current snapshot is
http://puck.informatik.med.uni-giessen.de/download/GISWxprint-sparc-2003-04-03-trunk.tar.gz).

Comment 9

14 years ago
That'd be great if I had permission to install it:(

Manually extracting and setting up a solaris package is a real pain.

I did a build of the Apr 1 nightly code and turned PostScript back on,
but it took for ever top build and mail slows down to the point of unusable. I
never saw that with your builds.
And I cannot use your build, becaus of psm problems.
(I encypted passwords and form data. I cannot access that or secure sites. 
File ./libfreebl_hybrid_3.so doesn't verify.)

Comment 10

14 years ago
Thomas Dodd:
| That'd be great if I had permission to install it:(

who installed GTK+ on your box? the same person can install the GISWxprint pkg
for you

2nd solution would be to get the Solaris binary tarball and install that in your
home directory

Comment 11

14 years ago
Masaki Katakai - are you working on this issue?
there are now more then 90 reports across the board reporting that Sun's version
of Xprt is complety broken
if you are not working on the bug - can you reassign the bug to someone who is
working on the problem or post his email that we can redirect all complaints to him?

Comment 12

14 years ago
The sysadmin install the Sun GNOME packages. Convincing him to install non-Sun
packges is another story.

Installing in my home directory is problematic. I'm already getting complaints
about my disk usage.

What other programs use Xprint? Anything reason to set it up other than for
mozilla? All the samples at xprint.mozdev.org are from mozilla based browsers.
not blocking development.
severity -> major
Severity: blocker → major

Comment 14

14 years ago
This bug is now fixed since a long time (see bug 191335).

See comments in http://xprint.mozdev.org/bugs/show_bug.cgi?id=3353 and
http://xprint.mozdev.org/docs/Xprint_FAQ.html#bug_solaris_xprt_removes_spaces_between_words

Solaris 2.8 and 2.9 patches are available now on http://sunsolve.sun.com/

Solaris 9 patch ids are:
For sparc: 112785-21 or later
For x86:   112786-11 or later

Solaris 8 patch ids are:
For sparc, 108652-73 or later
For x86, 108653-62 or later

Please read
http://xprint.mozdev.org/docs/Xprint_FAQ.html#bug_solaris_xprt_removes_spaces_between_words
for further information.
If there are still any problems please consult the Xprint mailinglist
(http://xprint.mozdev.org/list.html).

Marking bug as DUPlicate of bug 191335 ("Solaris 8 Xprint server broken").

*** This bug has been marked as a duplicate of 191335 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.