disable message boxes when I right click in a document

VERIFIED DUPLICATE of bug 86193

Status

()

Firefox
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 86193
15 years ago
15 years ago

People

(Reporter: Alex Knight-Percival, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030307 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030307 Phoenix/0.5

In an effort to warn people against reproducing images or text from a page, some
authors use event.button to check whether the right mouse button has been
pressed, and display a message box. Presumably the assumption is that the right
mouse button is used to copy images from a page. However, this interferes with
selecting any functions from the context menu. Furthermore, it makes
mouse-gesture style plugins, such as radial context, completely unusable. In the
`advanced javascript options' window (tools -> options -> web features ->
advanced), there should be an option to allow scripts to detect the right mouse
button, or something similar.

Reproducible: Always

Steps to Reproduce:
1. Load the test case

Actual Results:  
Pressing the right mouse button pops up a dialog box

Expected Results:  
Not displayed a dialog box if disabled by user prefs
(Reporter)

Comment 1

15 years ago
Created attachment 118982 [details]
HTML test case, which pops up a dialog box on right click

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.