Attempting to change focus on the Mail client completely froze Mozilla.

RESOLVED DUPLICATE of bug 216288

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 216288
15 years ago
14 years ago

People

(Reporter: John Malmberg, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
DEC
OpenVMS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenVMS COMPAQ_AlphaServer_DS10_466_MHz; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (X11; U; OpenVMS COMPAQ_AlphaServer_DS10_466_MHz; en-US; rv:1.3) Gecko/20030313

The browser completely locked up when I attempted to change the focus from one
mail account to another.

Reproducible: Didn't try

Steps to Reproduce:
1.Read e-mail from one account (POP3)
2.Attempt to read e-mail from a second account (IMAP SSL)
3.

Actual Results:  
The browser stopped responding.  I could bring up windows, and they painted, but
was unable to enter in new URLs.

Expected Results:  
It should have changed focus, and not locked up.

Mozilla 1.3

Mozilla/5.0 (X11; U; OpenVMS COMPAQ_AlphaServer_DS10_466_MHz; en-US; rv:1.3)
Gecko/20030313


EAGLE> set display/create/node=eagle/transport=local
EAGLE> @sys$common:[mozilla]mozilla
Starting mozilla-bin...

Gtk-CRITICAL **: file NL:[]GTKDND.C;: line 623: assertion `widget != NULL' faile
d.
[Control Y pressed -  Interrupt ]

EAGLE> exit
%SYSTEM-F-ACCVIO, access violation, reason mask=00, virtual address=000000000000
0000, PC=FFFFFFFF80C09C4C, PS=0000001B
%TRACE-F-TRACEBACK, symbolic stack dump follows
  image    module    routine             line      rel PC           abs PC
                                            0 FFFFFFFF80C09C4C FFFFFFFF80C09C4C
 LIBWIDGET_GTK  NSWINDOW  GetInnerMostWindow
                                        97645 00000000000017D4 0000000001FF1AE4
 LIBWIDGET_GTK  NSWINDOW  OnDragMotionSignal
                                       100277 000000000000A2E4 0000000001FFA5F4
 LIBWIDGET_GTK  NSWINDOW  FireDragMotionTimer
                                       100647 000000000000B468 0000000001FFB778
 LIBWIDGET_GTK  NSWINDOW  DragMotionTimerCallback
                                       100678 000000000000B6DC 0000000001FFB9EC
 LIBGLIB  GMAIN  g_timeout_dispatch     19923 0000000000001F34 0000000000163384
 LIBGLIB  GMAIN  g_main_dispatch        19265 0000000000000B80 0000000000161FD0
 LIBGLIB  GMAIN  g_main_iterate         19486 000000000000132C 000000000016277C
 LIBGTK  GTKMAIN  gtk_main_iteration    21967 0000000000000E50 00000000003E0160
 LIBWIDGET_GTK  NSDRAGSERVICE  GetTargetDragData
                                        69565 0000000000003038 0000000001FDD158
 LIBWIDGET_GTK  NSDRAGSERVICE  GetData  69209 0000000000001CE8 0000000001FDBE08
 LIBXPCOM  INVOKE  XPTC_InvokeByIndex    2497 00000000000000B0 00000000009C93B0
 LIBXPCONNECT  XPCWRAPPEDNATIVE  CallMethod
                                        65835 0000000000007594 0000000000F73FB4
 LIBXPCONNECT  XPCWRAPPEDNATIVEJSOPS  XPC_WN_CallMethod
                                        64004 00000000000050DC 0000000000F7E83C
 LIBMOZJS  JSINTERP  js_Invoke          19856 00000000000013C8 000000000065F7C8
 LIBMOZJS  JSINTERP  js_Interpret       21824 000000000000A458 0000000000668858
 LIBMOZJS  JSINTERP  js_Invoke          19873 0000000000001430 000000000065F830
 LIBXPCONNECT  XPCWRAPPEDJSCLASS  CallMethod
                                        63909 0000000000004CA4 0000000000F6B614
 LIBXPCOM  XPTCSTUBS_OPENVMS_ALPHA  PrepareAndDispatch
                                        12464 0000000000000364 00000000009CA8C4
 LIBXPCOM  STUBS  M64$$$CODE$             107 0000000000000048 00000000009C9418


EAGLE> show proc/quota/acc

31-MAR-2003 20:03:33.21   User: MALMBERG         Process ID:   0000015B
                          Node: EAGLE            Process name: "_FTA12:"

Process Quotas:
 Account name: SYSOP
 CPU limit:                      Infinite  Direct I/O limit:       150
 Buffered I/O byte count quota:    399808  Buffered I/O limit:     150
 Timer queue entry quota:             100  Open file quota:       4096
 Paging file quota:               2293840  Subprocess quota:        10
 Default page fault cluster:           64  AST quota:              248
 Enqueue quota:                      2000  Shared file limit:        0
 Max detached processes:                0  Max active jobs:          0

Accounting information:
 Buffered I/O count:        81  Peak working set size:       2944
 Direct I/O count:          24  Peak virtual size:         172032
 Page faults:              901  Mounted volumes:                0
 Images activated:           5
 Elapsed CPU time:          0 00:00:00.08
 Connect time:              1 18:41:46.01

Soft CPU Affinity: off

[The information below was collected after the restart]

EAGLE> show mem
              System Memory Resources on 31-MAR-2003 20:04:33.49

Physical Memory Usage (pages):     Total        Free      In Use    Modified
  Main Memory (256.00MB)           32768        6731       23591        2446

Virtual I/O Cache:                 Total        Free      In Use
  Cache Memory (MBytes)             3.12        0.00        3.12

Granularity Hint Regions (pages):  Total        Free      In Use    Released
  Execlet code region               1024           0         944          80
  Execlet data region                288           0         279           9
  S0/S1 Executive data region        779           0         779           0
  Resident image code region        1024           0         876         148

Slot Usage (slots):                Total        Free    Resident     Swapped
  Process Entry Slots                168         120          41           7
  Balance Set Slots                  166         127          39           0

Dynamic Memory Usage:              Total        Free      In Use     Largest
  Nonpaged Dynamic Memory (MB)      6.00        1.92        4.08        0.91
  Paged Dynamic Memory    (MB)      2.17        0.85        1.32        0.84
  Lock Manager Dyn Memory (KB)    496.00       65.50      430.50

Buffer Object Usage (pages):                  In Use        Peak
  32-bit System Space Windows (S0/S1)             14          15
  64-bit System Space Windows (S2)                 0           0
  Physical pages locked by buffer objects         14          15

Memory Reservations (pages):       Group    Reserved      In Use        Type
  Total (0 Bytes reserved)                         0           0

Swap File Usage (8KB pages):                   Index        Free        Size
  DISK$EAGLE:[SYS0.SYSEXE]SWAPFILE.SYS
                                                   1        1208        1656

Paging File Usage (8KB pages):                 Index        Free        Size
  (Paging file name not available)
                                                 253      150322      156248
  DISK$EAGLE:[SYS0.SYSEXE]PAGEFILE.SYS
                                                 254      150265      156248

  Total size of all paging files:                                     312496
  Total committed paging file usage:                                   26305

Of the physical pages in use, 5010 pages are permanently allocated to OpenVMS.

Comment 1

15 years ago
> Gtk-CRITICAL **: file NL:[]GTKDND.C;: line 623: assertion `widget != NULL' faile
d.

Assuming this message appeared at the time when you tried to change focus, I'd
say you actually performed a small drag operation rather than just a click.
Given this, can you try to reproduce the problem by performing very small drags
(I imagine just drag whatever to itself). Any chance you can remember exactly
where you clicked (dragged)?
(Reporter)

Comment 2

15 years ago
What I would have dragged is the scroll bar for the accounts and newsgroup pane
in order to look at a newsgroup after reading some e-mail.

This is something that I do all the time, and it does not usually cause a problem.

For some reason also when the browser hangs, a Control-y followed by an exit
command results in an access violation.  That should not happen.  Should that be
reported as a separate bug?

Comment 3

15 years ago
Bug 160509 is for a hang while dragging mail messages, and the GTK critical
message there is identical (same line number) to the one here. Coincidence, or dupe?

Comment 4

15 years ago
Bug 165554 sounds similar. That one got closed because no one else had seen the
problem.

And bug 216288 also talks of the GTKDND message followed by a hang.
(Reporter)

Comment 5

14 years ago
bug 216288 looks like the same bug.  It was still present in 1.5b, and I will
probably know with in a few days if it is present in 1.5.

Based on the comments in 216288, it looks like it is related to doing cutting
from one Mozilla window and pasting it into other windows and running out of
some resource quota.

*** This bug has been marked as a duplicate of 216288 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.