Tab bar around close button not repainting.

RESOLVED DUPLICATE of bug 195422

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 195422
15 years ago
9 years ago

People

(Reporter: Jason Bassford, Assigned: jag (Peter Annema))

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030331
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030331

Unfortunately, bug 199159 didn't resolve this specific repaint issue.

The following steps are easier to reproduce if you set the minimum tab width to
be greater than the default.  I.e. in userChrome.css add the following:

tab {min-width: 10em !important;}

Reproducible: Always

Steps to Reproduce:
1. Open enough tabs that you get overflow.
2. The close button should be seen on top of the right-most tab.
3. Click on a tab other than the right-most tab, in order to change focus to it.
4. Close enough tabs that there is no longer an overflow situation.
Actual Results:  
Artifacts are left around the close tab button.

Expected Results:  
The tab bar around the close tab button should have repainted, removing all
artifacts.

CCing roc (from bug 199159).
(Reporter)

Comment 1

15 years ago
Created attachment 119043 [details]
Tab bar around close button not repainting.

Of course, now that I've set out to reproduce this 100% I can't seem to.  I got
the screen capture as evidence, and I'm constantly seeing it, but when I wanted
to proove to myself I could get it to not repaint by following my own steps it
didn't cooperate.  Still, I know that if you play around with overflow and
focus (especially if you do a lot of tabbed browsing) this will occur.
(Reporter)

Comment 2

15 years ago
-> Tabbed Browser since it really is only a problem with the tab bar and no
other browser element I can see.
Component: Browser-General → Tabbed Browser
(Reporter)

Comment 3

15 years ago
I've been working with Bugzilla long enough, you'd think I'd know by now that
changing the Component doesn't automatically change who it's assigned to or the
QA contact...
Assignee: asa → jaggernaut
QA Contact: asa → pmac
(Reporter)

Updated

15 years ago
Keywords: regression
(Reporter)

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 195422 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.