Closed Bug 20009 Opened 20 years ago Closed Last year

No way to sort file:/// pages by Type

Categories

(Core :: XUL, enhancement, P3)

x86
All
enhancement

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: marshall, Assigned: janv)

References

Details

(Whiteboard: patch attached)

Attachments

(1 file, 1 obsolete file)

It would be nice to sort local files by type.  That way you could group the
directories together.  Right now they are mixed in with the filenames.
Attached patch Here is a patch to sort by type. (obsolete) — Splinter Review
Check out the patch and add this one line to the dtd file to get a Type column
in there.

<!ENTITY directoryWindow.contenttype.label "Type">

I can't believe I did something and it actually worked!  Currently it only
displays File/Directory and I'm not sure if it messes up the last modified
column as Windows doesn't display that info.
Whiteboard: patch attached
Chris Waterson - I think you wrote this originally, and there's a fix attached
to this bug, so you might want to take a look.  It's a good feature...
Assignee: leger → waterson
Target Milestone: M12
ok. i'll get it checked in.
Assignee: waterson → don
Target Milestone: M12
I'm gonna reassign this to you don, and clear the M12 milestone. The patch adds
a new column to the file viewer, and I'm not exactly sure if that's the UI we
want.
Summary: No way to sort file:/// pages by Type → [RFE] No way to sort file:/// pages by Type
Target Milestone: M15
Move to M15 for later evaluation.
QA Contact: leger → shrir
qa -> shrir
Move to M16 for now ...
Target Milestone: M15 → M16
Target Milestone: M16 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
See also bug 29247, [rfe] add a "type" column to directory listings.

Is this bug specific to local directory listings, or would it work on ftp 
listings?
Reassigning to a real person.
Assignee: vishy → Matti
QA Contact: shrir → asa
-> bbaetz
Assignee: Matti → bbaetz
Component: Browser-General → Networking: FTP
QA Contact: asa → benc
-> file +(really old) patch
Component: Networking: FTP → Networking: File
Keywords: patch
*** Bug 29247 has been marked as a duplicate of this bug. ***
Summary: [RFE] No way to sort file:/// pages by Type → No way to sort file:/// pages by Type
No need to add a new column to the GUI... The 'Type' column would be disabled by
default, and using the little button at the top right it can be checked on.

CC'ing me and adding my vote. I think it's important to have the possibility of
grouping files by extension.
Attachment #3021 - Attachment is obsolete: true
Attachment #3021 - Attachment is patch: true
Attachment #3022 - Attachment is patch: true
Patch is probably out of date (from 1999). 

It would be nice to sort by date, last modified, file size, name, etc. Couldn't
we do this with XUL? 
-> tree this patch probably works for tree and not HTML view...

please send it back if I got it wrong...
Assignee: bbaetz → varga
Component: Networking: File → XP Toolkit/Widgets: Trees
QA Contact: benc → shrir
cc'ing people who might be interested
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets
I checked the directory listing and I don't think adding a new column is necessary anymore. When I click on the "Name" column header, the listing becomes sorted by name and directories get shown first.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.