Problems while compiling; configure is OK, but "make" doesn't work

VERIFIED DUPLICATE of bug 196004

Status

SeaMonkey
Build Config
--
blocker
VERIFIED DUPLICATE of bug 196004
15 years ago
2 years ago

People

(Reporter: Sylvain Arnaud, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020920 Netscape/7.0
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020920 Netscape/7.0

It seems my "ld" doesn't want nsprmap.sun...


Reproducible: Always

Steps to Reproduce:
1. Under Sun Solaris 8, with gnu-gcc-3.0.4 and binutils-2.11.2
2. setenv LD_LIBRARY_PATH
<path to libIDL-0.6.8>:<path to gtk+-1.2.10>:<path to glib-1.2.10>:<path to
freetype-2.1.0>:<path to
gcc-3.0.4-binutils-2.11.2>:/usr/lib:/usr/openwin/lib:/usr/dt/lib
3. ./configure --prefix=/local/Softs/mozilla-1.3
4. make

Actual Results:  
The "make" fails at this step:

gcc -B/usr/ccs/bin/ -shared -Wl,-h,libnspr4.so,-z,combreloc,-z,defs
-Wl,-f,\$ORIGIN/cpu/\$ISALIST/libnspr_flt4.so -o libnspr4.so
-Wl,-M,./nsprmap.sun ./prvrsion.o io/./prfdcach.o io/./prmwait.o io/./prmapopt.o
io/./priometh.o io/./pripv6.o io/./prlayer.o io/./prlog.o io/./prmmap.o
io/./prpolevt.o io/./prprf.o io/./prscanf.o io/./prstdio.o threads/./prcmon.o
threads/./prrwlock.o threads/./prtpd.o linking/./prlink.o malloc/./prmem.o
md/./prosdep.o memory/./prshm.o memory/./prshma.o memory/./prseg.o
misc/./pralarm.o misc/./pratom.o misc/./prcountr.o misc/./prdtoa.o
misc/./prenv.o misc/./prerr.o misc/./prerror.o misc/./prerrortable.o
misc/./prinit.o misc/./prinrval.o misc/./pripc.o misc/./prlog2.o misc/./prlong.o
misc/./prnetdb.o misc/./prolock.o misc/./prrng.o misc/./prsystem.o
misc/./prthinfo.o misc/./prtpool.o misc/./prtrace.o misc/./prtime.o
malloc/./prmalloc.o pthreads/./ptsynch.o pthreads/./ptio.o pthreads/./ptthread.o
pthreads/./ptmisc.o md/unix/./unix.o md/unix/./unix_errors.o
md/unix/./uxproces.o md/unix/./uxrng.o md/unix/./uxshm.o md/unix/./uxwrap.o
md/unix/./solaris.o md/unix/./os_SunOS.o -lpthread -lthread -lrt -lsocket -lnsl
-ldl -lc
./nsprmap.sun: file not recognized: File format not recognized
collect2: ld returned 1 exit status
make[4]: *** [libnspr4.so] Error 1
make[4]: Leaving directory `/local/Softs/SRC/tmp/mozilla/nsprpub/pr/src'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/local/Softs/SRC/tmp/mozilla/nsprpub/pr'
make[2]: *** [export] Error 2
make[2]: Leaving directory `/local/Softs/SRC/tmp/mozilla/nsprpub'
make[1]: *** [nspr] Error 2
make[1]: Leaving directory `/local/Softs/SRC/tmp/mozilla'
make: *** [default] Error 2


Expected Results:  
A good compilation

Comment 1

15 years ago
I have found a similar problem while compiling Mozilla 1.3 on Solaris 2.6 using
Forte 6 Update 2. I think it's related to the 'ld' in /usr/ccs/bin on Solaris 2.6

I dont get this problem when i try to compile Mozilla 1.3 on Solaris 9 using
Forte 7.
I'd also be interested in seing if people have any idea's as i need to get a
version of Mozilla which will work on Solaris 2.5.1 and Solaris 2.6
Summary: Problems while compiling; configure is OK, but "make" doesn't work → Problems while compiling; configure is OK, but "make" doesn't work

Comment 2

15 years ago
Reporter:
Did you apply the latest version of the linker patch for your OS version (which
are part of Sun's public "Recommended&Security" patch cluster) ?
(Reporter)

Comment 3

15 years ago
Nothing new after installing the last recommended patch cluster for Solaris 8.
But it is not a surprise, as I am compiling with GNU gcc and not SUN cc, so the
linker used is the GNU one...

If I do a truss command, it shows:

access("/_TOOLS_/dist/gnu-gcc-3.0.4-binutils-2.11.2/sparc64-sun-solaris2.8/bin/../lib/gcc-lib/sparc-sun-solaris2.8/3.0.4/collect2",
1) = 0
fork()                                          = 7667
./nsprmap.sun: file not recognized: File format not recognized
collect2: ld returned 1 exit status

So it seems the problem come after the fork() command...

*** This bug has been marked as a duplicate of 196004 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
Our fixes for this problem are in the Mozilla 1.4 Alpha release.
I'd appreciate it if you could download and build Mozilla 1.4
Alpha and see if any build problem still remains.  Thanks.
(Reporter)

Comment 6

15 years ago
I cannot find the source file; the links are broken under the site download page...
No src directory under http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4a/

Comment 7

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Created attachment 8681814 [details] [review]
[gaia] veer66:master > mozilla-b2g:master
Attachment #8681814 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.