Pasting search text via context menu (right-mouse) does not paste from windows clipboard

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Mark Dickens, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Pasting search text via context menu (right-mouse) does not paste from windows
clipboard.
Rather it removes focus from the text-box (and indeed the dialog).
Standard keyboard shortcuts do work though.

Reproducible: Always

Steps to Reproduce:
1.Copy desired search text to clipboard
2.Select a newsgroup (account)
3.Open Search Messages dialog and select search text text-box.
4.Right mouse click and select Paste item

Actual Results:  
It removes focus from the text-box (and indeed the dialog).

Expected Results:  
It should paste the text from the clipboard into the selected text-box

Comment 1

15 years ago
reporter have you looked at bug 195260?
(Reporter)

Comment 2

15 years ago
I have looked at it. It is similar, and may be the root cause is the same but it
is not possible to say.

Comment 3

15 years ago
To narrow it down a bit : do you ONLY have problems pasting from Office XP, or
also from other apps?
(Reporter)

Comment 4

15 years ago
I am not using Office XP (at least not if I can help it :-)), but it may be the
Windows XP clipboard at fault. OTOH the loss of focus from the Search Messages
dialog suggests to me that Mozilla may not be entirely innocent.

Comment 5

15 years ago
Mark, this works now with Mozilla 1.6 (Win2k) and that other bug has been fixed
since you reported this one. I'm not sure if they are connected, but please try
again and say if this still happens for you.
(Reporter)

Comment 6

15 years ago
This now works with Mozilla 1.6 (WinXP)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
Then the proper resolution is WORKSFORME (FIXED only when the patch that fixed
it is identified). Reopening to correct that.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.