some tables don't display properly

RESOLVED WORKSFORME

Status

--
trivial
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: fabrizio.larosa, Assigned: bryner)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

It could happen that some HTML pages containing tables doesn't display correctly
in Camino 0.7, while other browsers display them with the table correctly aligned.
This sometimes happens also at the URL 
http://www.versiontracker.com/macosx/index.shtml

Reproducible: Sometimes

Steps to Reproduce:
1.open the page at the URL indicated above
2.
3.

Actual Results:  
the table in that page doesn't display properly

Expected Results:  
the table in the page should be aligned correctly
(Reporter)

Comment 1

16 years ago
I forgot the URL where I noted this bug for the first time:
http://www.commputercations.com/GSA/gsanbase.htm

Comment 2

16 years ago
Fabrizio, do you have HTTP Pipelining enabled?

This could be a dup of bug 195746, which is fixed. Try a current nightly build.
(Reporter)

Comment 3

16 years ago
I can reproduce this problem about 2 times out of 10 using the stable release of
Camino 0.7
did not yet tried with a nightly build
(Reporter)

Comment 4

16 years ago
what is "HTTP pipelining"?
If you refer to the "Load opened windows ot tabs in background", it is disabled.

Comment 5

16 years ago
HTTP Pipelining is an experimental networking feature designed to improve
performance, but it has some bugs.

Check your prefs.js and user.js files for a line that looks like:
user_pref("network.http.proxy.pipelining", true);

It's disabled by default, but you may have used a program such as ChimeraBooster
or SpeedChimera to enable it in the past.

Comment 6

16 years ago
Fabrizio, can you still reproduce this bug in current Camino nightly builds? if
so can you please attach a screen shot. thx
(Reporter)

Comment 7

16 years ago
Created attachment 123612 [details]
screenshots from official release and latest nightly build

I have attached a zip file containing two screenshoots: one from the official
0.7 release of Camino (where you can see the effects of this bug) and another
one from the 2003051715 nightly build.
Now it works better than before, but on the first load of a page containing
some kind of tables the header of the table is not well aligned with the rest
of the table itself (see screenshoot).
Btw I noted that reloading the page, or when the page already is in the cache,
the table is correctly shown, even with the stable 0.7 release.
(Reporter)

Updated

16 years ago
Summary: some tables doesn't display properly → some tables don't display properly

Comment 8

16 years ago
Fabrizio, can you also reproduce this with a current Mozilla build?
(Reporter)

Comment 9

16 years ago
I tried it with the stable release of Mozilla 1.3 and it works correctly.

Comment 10

16 years ago
Fabrizio, try temporarily testing using a new Camino user profile by temporarily
relocating your <~/Library/Application Support/Chimera/Profiles/default> folder.

Comment 11

15 years ago
i don't know if this is a dup, but this was the closest bug i could find in the
list.

when i visit the site 

http://phpdocu.sourceforge.net/

the tables are not displayed correctly (tables at the left side are displayed at
the bottom of the tables on the right side). However, when you press refresh,
the page is displayed correctly.

User-Agent : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516
Mozilla Firebird/0.6


I tried the site in the orignal report
(http://www.versiontracker.com/macosx/index.shtml) and it look fine to me.
Created attachment 130426 [details]
useable screenshot

Fabrizio is this whta you are describing ? screen shot done with 2003082402.
Problem is present with Camino 2003082402.
Problem is present in Mozilla 2003052808 [upgrading Mozilla].
Problem is no more present in Mozilla 2003082603.
Problem is not present in IE Mac neither in Safari 1.0.

Can someone test with a newer Camino build ?

Comment 14

15 years ago
odd... i'm not seeing this with camino 2003082602... and i didn't see it when i
made comment 6 either.

so what is different about your camino setup Ludovic? Are you using an old
profile when you see this?

(marking NEW since someone else is reproducing)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yes I have a quite old profile. I will test with new one and update. But first I
need to go thru bryner's Camino bug and add comments so Mike can triage a little
better.
Tested with a fresh profile problem is still here.
(Reporter)

Comment 17

15 years ago
Yes, the screenshot posted by Ludovic perfectly reproduces the bug that I initially reported here.
Funny I've been trying to reproduce un order to have a simplified test case. I
could reproduce, half the time. I then cleared the disk cache using
preference->History->Clear Disk Cache and Hva enot been able to reproduce.
Fabrizio would you please download a nightly build of Camino, clear disk cache
and try to reproduce and post some comments here ?

Comment 19

15 years ago
The url's work in Mozilla 1.6 and 1.7. But we still have this issue?
Perhaps it's due to QuickDraw?
(Reporter)

Comment 20

15 years ago
Just tried again with Camino nightly build 2004021008 and it seems to work
properly now.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.