unclosed <a> before <ul><li> makes first <a> in <li> cause line break

RESOLVED FIXED

Status

()

Core
HTML: Parser
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: ben-bugzilla, Assigned: harishd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Well-formed (well, it validates) xhtml file at given URL renders with a spurious
carriage return after the first :

My apologies if this is a duplicate.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 119109 [details]
Test case
Created attachment 119115 [details]
same testcase, XHTML MIME type

How about an xmlns this time?
Attachment #119114 - Attachment is obsolete: true
Since you're not following the guidelines in Appendix C of XHTML for sending
XHTML as text/html, marking invalid.

See http://www.w3.org/TR/xhtml1/#C_3

Note that if you want us to process the document as XHTML, you need to use
application/xhtml+xml (or text/xml, etc., but the first is preferred).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Layout: Block & Inline → Parser
Resolution: --- → INVALID
*** Bug 219836 has been marked as a duplicate of this bug. ***
maybe we should consider fixing, since it can happen in older pages too (<a
name> often lacks an end tag).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: extra newline spuriously inserted in <li> with xhtml strict → unclosed <a> before <ul><li> makes first <a> in <li> cause line break
->Parser
Assignee: block-and-inline → harishd
Status: UNCONFIRMED → NEW
Ever confirmed: true
Marking FIXED, as this no longer appears in current builds. I believe this was
fixed by bug 181697, but it isn't a dupe so simply marking it as fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → FIXED
*** Bug 100930 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.