High CPU usage at iht.com (element repositioned continuously by js in very short intervals)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: mattwilkens, Assigned: asa)

Tracking

({regression, testcase})

Trunk
x86
Linux
regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030331
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030331

Visiting http://iht.com pegs CPU usage at about 70%.  Rendering of the pages
seems to be fine.  Hadn't seen this problem with 1.3; only noticed it after
moving to a 1.4a trunk build. 

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
Hm, there's some Javascript code running. Turn JS off and no CPU usage.
Didn't track it down yet.

Comment 2

16 years ago
I can reproduce this CPU load with 2003040405 on Linux.
And I also can't reproduce it with 1.3 final.

In the function placeNavBar (in ihtEventsWindow.js) a value is assigned to
obj.style.top where obj = document.getElementById("navTop"); This function is
called every 20ms.

If comment the assignments to obj.style.top out and the CPU load is gone.

There must have been a change anywhere which caused this since release of 1.3,
but don't know if it's in JS engine or somewhere else.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Created attachment 119455 [details]
Testcase derived from iht.com

This testcase should be helpful though the CPU load produced isn't that high.
But the problem is the same.

Comment 4

16 years ago
no CPU problem on win98 (moz2003040308)
Keywords: regression
Summary: High CPU usage at iht.com → High CPU usage at iht.com (element repositioned continuously by js in very short intervals)

Updated

16 years ago
Keywords: testcase

Comment 5

16 years ago
Might be related to layout bug http://bugzilla.mozilla.org/show_bug.cgi?id=172835

Still seems to happen with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.4) Gecko/20030529 [1.4RC1]

Updated

16 years ago
Blocks: 202567
(Reporter)

Comment 6

15 years ago
I've seen this bug on versions through 1.4.1, but it seems to have gone away in
1.5 on Linux.  Perhaps someone can verify.
(Assignee)

Comment 7

15 years ago
wfm per reporter's comment
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 8

15 years ago
*** Bug 213116 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.