If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Heavy disk activity, locking mozilla for 5 minutes, upon mail check

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Todd, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

This problem is not triggered by specific user input, it seems to happen when
Mozilla checks mail status on the IMAP server.

I see the mail notification popup, saying there are 'x' new messages, then
Mozilla starts to access the hard drive.  It grinds away for 5-6 minutes, during
which time Mozilla is completely unusable (both the mail and browser portions),
and the rest of the system is slowed.      It almost seems like the system is
violently swapping,  but the Win2K free memory, and task manager paging
statistics show that it is not swapping.

After the disk activity stops, Mozilla is again usable, and seems unaffected by
the 5 minutes of disk crunching.

System info:  IBM Thinkpad T22, P3 900MHz, 256MB RAM, Windows 2000 SP1
Messenger is accessing E-mail via IMAP

Reproducible: Sometimes

Steps to Reproduce:
(Assignee)

Comment 1

15 years ago
do you have your inbox configured for offline use? Do you have mozilla
configured to compact local mailboxes when it will save XX kb?
(Reporter)

Comment 2

15 years ago
> do you have your inbox configured for offline use? 

Yes, this option is enabled.     I usually have between 50 and 200 messages in
my inbox at any given time, most of which are relatively small.
No other folders are selected for offline access.

> Do you have mozilla configured to compact local mailboxes when it will save XX kb?

No, this option is disabled.

---------

Note that this behavior happens approximately once per day. Sometimes twice, but
not usually.

The storage folders on my IMAP server are rather large,  some containing ~3000
messages.  But, the Inbox is kept relatively small.
(Assignee)

Comment 3

15 years ago
how big is the offline INBOX? It might be getting quite large if it's never
compacted. It's in a file called INBOX in your imap server sub-directory of your
local user profile directory.
(Reporter)

Comment 4

15 years ago
> how big is the offline INBOX?

Wow...  I checked that directory, and the INBOX file was over 500MB.   I looked
at the beginning of that file, and there was mail in there from over a year ago.
  Messages are usually only in my inbox for a few hours, before they are moved
to a folder or deleted.   So, this is definitely not the behavior I expected.

Also,  I periodically do the "Compact Folders" option in the File menu of the
mail client.   I assumed this had the same behavior as the Compact option in the
preferences menu.. but, apparently not.
(Assignee)

Comment 5

15 years ago
yeah, compact folders should compact the offline stores as well. I'll try to see
why it doesn't.
(Reporter)

Comment 6

15 years ago
I turned on the option to compact folders,  and manually selected the compact
folders option in the file menu, and it didn't effect that huge inbox file.

I then turned off the option to save my inbox for offline access (I have had bad
luck with that feature, I was never actually able to read most messages when not
online).   This also did not effect the huge file.   I stopped & restarted
mozilla, still no effect.

I will manually rename the file, and see if that changes the behavior.

Some more details on the problem,  how it happened today:

1:39 - Booted thinkpad, started Win2K.  A couple background apps running (VPN
client, NTP Time client, AV),  Mozilla and SecureCRT (SSH Client) only
foreground apps started.
1:40 - Checked two web sites, and authenticated to IMAP server, updates message
list.
1:44 - Disk starts grinding.  Mozilla unresponsive.  SecureCRT still usable,
system seems fine, other than Mozilla.
1:52 - Disk stops grinding.  Mozilla resumes normal operation.
(Assignee)

Comment 7

15 years ago
do you have a virus checker running?

the times at which we compact the offline stores are screwy, to say the least.
But one way to get them compacted is to select a local folder, i.e., not an imap
folder. The other way is to hit get msg twice quickly (I said it was screwy)
(Reporter)

Comment 8

15 years ago
> do you have a virus checker running?

Yes, I do have Trend Micro Officescan running.   
But, I don't think it's involved with the behavior, as it only effects Mozilla,
and the Win2K task manager does not show officescan as actively using resources
when this is happening.


I removed the INBOX file yesterday,  and since then have not seen the problem..
 I'll wait a few days to declare victory, but it seems like that was the problem.
(Assignee)

Comment 9

14 years ago
marking wfm - I did fix doing a compact while offline to compact the offline store.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.