"No running window found" error occurs on launching Mozilla (load continues sucessfully though)

RESOLVED DUPLICATE of bug 240174

Status

--
trivial
RESOLVED DUPLICATE of bug 240174
16 years ago
14 years ago

People

(Reporter: james, Assigned: asa)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.2.1) Gecko/20030331
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.2.1) Gecko/20030331

Possibly depends on end-user launching mozilla

Reproducible: Sometimes

Steps to Reproduce:
1. Under csh with system as detailed above, launch mozilla in x terminal by
typing "mozilla" 
2. 
3.

Actual Results:  
"No running window found" error printed to stdout/stderr (I'm using XFree86
4.3.0 on FreeBSD stable 4.8rc BTW)

Expected Results:  
Been quiet

Mozilla also silently crashes later during a session though this is probably
unrelated.  I track FreeBSD stable and portversion indicates that all is up to
date. Have recently removed the Xft dependency as before that mozilla wouldn't
even launch. (n.b. FreeBSD port indicates that mozilla + Xft is broken)

Comment 1

16 years ago
I see this too (Moz1.3.1 on FreeBSD 5.1), but I don't think this is an error,
but rather an informational message. When you start Mozilla having at least one
instance of Mozilla already running, the "error" won't show up. Mozilla may be
referring to its own windows, when printing "No running window found". James, if
you agree we can close this bug marking it as invalid.
(Reporter)

Comment 2

16 years ago
Yes,

It does appear to be an informational message (on stderr?). I just think it's
not particularly helpful - indeed it's confusing until you realise that it is
mozilla referring to it's own windows! IMHO mozilla should just launch silently
without this message.

P.s. the crashes were unrelated as far as I can tell. They seem to have
mysteriously disappeared since I upgraded to 1.3.1,2 - I guess this may have
been a problem with the previous FreeBSD port.

Comment 3

15 years ago
I just installed a fresh FreeBSD 4.9-RELEASE system, checked out a fresh ports
tree and built mozilla.  I get this error, and then mozilla shutsdown with no
further action or messages...  It does it whether I'm running Afterstep, KDE or
Gnome.

Comment 4

15 years ago
I ktrace'd mozilla and found that my .mozilla directory was owned by root for
some reason.  mozilla was silently quitting when it couldn't write to the
directory.  Changing the ownership fixed the problem, though mozilla should
issue an error message rather than silently dying...

Comment 5

15 years ago
Me in roughly the same state
FreeBSD 4.8-RELEASE, buliding from ports.
I know of someone else with a similar setup and when I copy over the binaries,
it does work. Though I havent been able to put my finger on the bug, it exists
with both mozilla and firefox

(In reply to comment #3)
> I just installed a fresh FreeBSD 4.9-RELEASE system, checked out a fresh ports
> tree and built mozilla.  I get this error, and then mozilla shutsdown with no
> further action or messages...  It does it whether I'm running Afterstep, KDE or
> Gnome.
Product: Browser → Seamonkey

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 240174 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.