For style="TEXT-ALIGN:Right" in textField Cursor not visible till atleast one character is entered.

RESOLVED DUPLICATE of bug 105397

Status

RESOLVED DUPLICATE of bug 105397
16 years ago
14 years ago

People

(Reporter: ashok_gce, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (os/2; U; Warp 4.5; en-US; rv:1.2a)

for the below code cursor is not visible even the focus is on that field.

<input type="text" name="b12c96nfConstr_2" id="Constr_3" 
 maxlength="13" style="TEXT-ALIGN:Right"/>

Since the text is right aligned, until we enter atleast minimum of one 
character cursor is not visible. this makes the feeling to the user the field 
as read only.

Reproducible: Always

Steps to Reproduce:
1.Copy the below code.
<HTML>
  <HEAD>
    <TITLE></TITLE>
  </HEAD>
  <BODY>
  <input type="text" name="b12c96nfConstr_2" id="Constr_3" 
 maxlength="13" style="TEXT-ALIGN:Right"/>

  </BODY>
</HTML>

2.Click on the field.


Actual Results:  
No cursor.

Expected Results:  
Cursor should blink on the right side inside the field.
(Reporter)

Updated

16 years ago
OS: other → OS/2

Comment 1

16 years ago
Please try a newer build, this has been fixed.
Reopen if you can reproduce with a newer build.

*** This bug has been marked as a duplicate of 105397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Can u please tell me where can I find the newer build for OS/2.
I am able to find only for windows etc. not for OS/2.
The build I am using is: Mozilla/5.0 (os/2; U; Warp 4.5; en-US; rv:1.2a)
(Reporter)

Comment 4

16 years ago
Thanks for the information.

There is one more problem faced by me.I am not creating new bug for this 
because this may be already reported.

The problem is with link.
My HTML page uses two three external javascript like this.

<SCRIPT language="JavaScript" src="MyScript.js">;
				</SCRIPT>
<SCRIPT>if (typeof(MyScript) == "undefined") alert("Could not load 
MyScript.js");</SCRIPT>


I am having a variable defined in MyScript.js 
var MyScript = true;

Everything is cool when we work with the page professionally.
But the problem arise when the user clicks a link in the page continously.

I am getting the alert message "Could not load MyScript.js" and if we click ok 
leads to error page.

Expected result is when we click that link should open, another page.

It seems that when we click that link continously, the current page itself gets 
reloaded and not able to find the associated javascript file.

I don't know really this is a problem in mozilla or there is something wrong in 
my code.But working fine in IE.

Thank you once again.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.