select boxes hardly usable with mouse when css active color atribute set

RESOLVED DUPLICATE of bug 154670

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 154670
15 years ago
15 years ago

People

(Reporter: Doncho N. Gunchev, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030315
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030315

When there is style like this:
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>Title Here</title>
    <style type="text/css">
; :link		{ color: #1111ff }
; :visited	{ color: #2222ff }
:active		{ color: #ff1111 }
    </style>
  </head>

clicking on the document flashes normal text & select boxes in red making also
select boxes "hardly" usable - you have to click three times to pull them down.


Reproducible: Always

Steps to Reproduce:
1. create the following html page
--- cut ---
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>Title Here</title>
    <style type="text/css">
; :link		{ color: #1111ff }
; :visited	{ color: #2222ff }
:active		{ color: #ff1111 }
    </style>
  </head>

  <body>
    <center>
    <form method="POST" action="act.pl" enctype="application/x-www-form-urlencoded">
      <h3>H3 Here</h3>
      <input type="hidden" name="id" value="1" />
      <input type="hidden" name="name" value="name" />
      s1
      <select name="s1">
        <option value="1">1</option>
        <option value="2">2</option>
        <option value="3">3</option>
      </select>
      s2
      <select name="s2">

        <option selected value="0">0</option>
        <option  value="1">1</option>
        <option  value="2">2</option>
        <option  value="3">3</option>
        <option  value="4">4</option>
        <option  value="5">5</option>
        <option  value="6">6</option>
        <option  value="7">7</option>
        <option  value="8">8</option>
        <option  value="9">9</option>
        <option  value="10">10</option>
      </select>
      <select name="S3">
        <option selected value="0">0</option>
        <option  value="5">5</option>
        <option  value="10">10</option>
        <option  value="15">15</option>
        <option  value="20">20</option>
        <option  value="25">25</option>
        <option  value="30">30</option>
        <option  value="35">35</option>
        <option  value="40">40</option>
        <option  value="45">45</option>
        <option  value="50">50</option>
        <option  value="55">55</option>
        <option  value="60">60</option>
        <option  value="65">65</option>
        <option  value="70">70</option>
        <option  value="75">75</option>
        <option  value="80">80</option>
        <option  value="85">85</option>
        <option  value="90">90</option>
        <option  value="95">95</option>
      </select>
      <br />
      <br />
      <br />
      <hr />
      <input type="submit" name="a1" value="a1" />
      <input type="submit" name="a2" value="a2" />
      <input type="button" name="cancel" value="cancel"
onclick="javascript:window.close();" />
    </form>
    </center>
  </body>
</html>
2. Open it in mozilla (navigator)
3. Try pulling down the select boxes and left clicking all around the document.

Actual Results:  
The normal text flashes when pressing left mouse button over the document and if
you try to pull down the select boxes you have to tricky click them 3 times to
open... (not always)


Expected Results:  
If every other browser (netscape, MSIE, konqueror and opera) works fine...
mozilla should too I think...

Mozilla 1.3 on RedHat Linux 8.0 last updated 2003.03.20 or so, Duron 700, ECS
K7S5A motherboard, 256 DDR, NVidia kernel driver... but these should not be
important...
(Reporter)

Comment 1

15 years ago
Created attachment 119178 [details]
the document I used (stripped down a bit)

Comment 2

15 years ago
dupe of "drop-down select menu closed by DOM/CSS events."

*** This bug has been marked as a duplicate of 154670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.