If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

download manager still downloads file, although it's cancelled

RESOLVED DUPLICATE of bug 157548

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 157548
15 years ago
4 years ago

People

(Reporter: mosez, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

while downlading the same file from different servers to the same location of
the harddisk (using same filenames), the download manager switches ervery few
seconds (2-4 secs) between theese 2 downloads, and doesn't show 2 different
lines for the download. (it s downloaded twice) if you are cancelling this
dual-download, only one of them is really cancelled, and the line in the
downloadmanager is deleted. but mozilla is still downloading the file (from the
first server, i think). i recognized it cause, there was still heavy traffic
although i was doing nothing.

Reproducible: Always

Steps to Reproduce:
1.choose a file, which is on different mirrors.
2.download it from the first mirror
3.download it from a second mirror, use same directory, use same filename
4.cancel the download in downloadmanager
5.mozilla is still downloading the file, although nothing is shown in the
downloadmanager

Actual Results:  
mozilla is still downloading the file

Expected Results:  
cancel both downloads

maybe 2 differnt lines in the downloadmanager?
Whiteboard: DUPEME

Comment 1

14 years ago
This is a confirmed bug on Mozilla 1.7b running Windows XP Professional.
Product: Browser → Seamonkey

Comment 2

13 years ago
related/dup: bug 157548

*** This bug has been marked as a duplicate of 157548 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.