M140A crash [@ nsAccessibilityService::GetHTMLObjectAccessibleFor]

RESOLVED WORKSFORME

Status

()

Core
Disability Access APIs
--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Jan Carpenter, Assigned: Aaron Leventhal)

Tracking

({crash, qawanted, topcrash})

Trunk
x86
Windows 2000
crash, qawanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
This stack signature is a topcrash on M130

   Unique Users:          32

   Stack Trace: 
   nsAccessibilityService::GetHTMLObjectAccessibleFor
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1416]
   nsAccessibilityService::GetAccessibleFor
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1569]
   nsRootAccessible::HandleEvent
[c:/builds/seamonkey/mozilla/accessible/src/base/nsRootAccessible.cpp  line 496]
   nsRootAccessible::Focus
[c:/builds/seamonkey/mozilla/accessible/src/base/nsRootAccessible.cpp  line 641]
   nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1722]
   nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp  line 2578]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3336]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
   nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 4499]
   GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 801]
   nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp  line 3521]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1889]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsHTMLFormElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLFormElement.cpp 
line 749]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1882]
   nsHTMLInputElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLInputElement.cpp 
line 1456]
   nsEventStateManager::SendFocusBlur
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 4227]
   nsEventStateManager::SetContentState
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3920]
   nsHTMLInputElement::SetFocus
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLInputElement.cpp 
line 1083]
   nsEventStateManager::ChangeFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2888]
   nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 1806]
   PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6267]
   PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6181]
   nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2212]
   nsView::HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 304]
   nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 1948]
   HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 83]
   nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1120]
   nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1137]
   nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5385]
   ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5640]
   nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 4134]
   nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1404]
   USER32.dll + 0x27ad7 (0x77d67ad7)
   USER32.dll + 0x2ccd4 (0x77d6ccd4)
   USER32.dll + 0x4455 (0x77d44455)
   USER32.dll + 0x95d5 (0x77d495d5)
   nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480]
   main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1289]
   main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1639]
   WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1660]
   WinMainCRTStartup()
   kernel32.dll + 0x214c7 (0x77e814c7)

    Source File: 
c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp line
: 1416

   (18694769)      URL: us.f804.mail.yahoo.com
   (18683508) Comments: I contactet to my library
   (18682874) Comments: Used Tab
   (18659901)      URL: us.f804.mail.yahoo.com
   (18652000)      URL: https://rx.prevacid.com/quizzes/prev04.asp
   (18652000) Comments: CLICKING ON A BUTTON TO ANSWER A QUESTION
   (18648478)      URL: us.f804.mail.yahoo.com
   (18635118) Comments: I tried to contact to ebay  my ebay.
   (18567692) Comments: clicking on radio button  
   (18562193)      URL: us.f804.mail.yahoo.com
   (18562193) Comments: clicked in checkbox
   (18560742)      URL: bugzilla.mozilla.org
   (18560742) Comments: tabbed into checkbox
   (18560377)      URL: bugzilla.mozilla.org
   (18560377) Comments: clicking a radio box
   (18556684)      URL: edit.profiles.yahoo.com
   (18556684) Comments: clicked a radio button
   (18556572) Comments: yahoo mail
   (18534077)      URL: creative.com
   (18534077) Comments: clicked on a radio button
   (18491195)      URL: arstechnica.org
   (18491195) Comments: clicked a radio button
   (18488989)      URL: www.google.co.uk
   (18488989) Comments: Hotmail
   (18472665)      URL: www.getmycard.com
   (18472665) Comments: As I atempted to complete the signin page  the program
crashed.
   (18446215)      URL: www.ups.com/tracking/tracking.html
   (18446215) Comments: Clicking a radio button
   (18446034)      URL: www.ups.com/tracking/tracking.html
   (18446034) Comments: clicking a checkbox - high memory load situation
   (18441816) Comments: executing php script i.e. sending emial from a formside
   (18438339)      URL: us.f804.mail.yahoo.com
   (18438339) Comments: clicking a checkbox
   (18438228)      URL: us.f804.mail.yahoo.com
   (18438228) Comments: clicking a checkbox. appears to be related to high
memory load
   (18413260)      URL: us.f804.mail.yahoo.com
   (18413260) Comments: clicked a radiobutton
   (18408414)      URL: us.f804.mail.yahoo.com
   (18408414) Comments: clicking a checkbox
   (18385231)      URL: www.tmobile.com
   (18369293) Comments: checking my Hotmail inbox with the browser  as launched
by MSN Messenger 4.6.    I had to launch it twice because the first time  I got
a dialog box saying that a file in C:\WINDOWS\TEMP wasn't found.  Then I read
some of my messages  and it was when I
   (18369293) Comments:  tried to delete some messages that it crashed.
   (18364216) Comments: reading slashdot  klicking on one of the poll options

Comment 1

15 years ago
*** Bug 200371 has been marked as a duplicate of this bug. ***
What does this have to do with the DOM?  And if this is 1.3, I doubt this is
branch....
Assignee: dom_bugs → aaronl
Component: DOM HTML → Accessibility APIs
QA Contact: desale → dsirnapalli
Version: 1.0 Branch → Trunk

Updated

15 years ago
Severity: normal → critical

Comment 3

15 years ago
Created attachment 119716 [details]
Talkback data for 18694769

Comment 4

15 years ago
i think something was treating 0x1 as an object. perhaps another xpt nightmare?

Comment 5

15 years ago
Updating summary with M140A since this continues to show up on the topcrash
radar for Mozilla 1.4 Alpha.  Also adding qawanted to see if we can get this
reproduced.  Here is the latest from Talkback:

 (35)  	 19  	 nsAccessibilityService::GetHTMLObjectAccessibleFor
 
  	200370 	NEW 		aaronl@netscape.com 	--- 	2003-04-07

   BBID range:            19267162 - 19550546
   Secs since last crash: 94 (min) - 1015927 (max)
   Total Runtime:         1776 (min) - 1015927 (max)
   Crash date range:      2003-04-18 to 2003-04-27
   Crash date range:      2003040105 to 2003040105
   Unique Users:          13


   Stack Trace: 
   nsAccessibilityService::GetHTMLObjectAccessibleFor
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1444]
   nsAccessibilityService::GetAccessibleFor
[c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp 
line 1609]
   nsRootAccessible::HandleEvent
[c:/builds/seamonkey/mozilla/accessible/src/base/nsRootAccessible.cpp  line 492]
   nsRootAccessible::Focus
[c:/builds/seamonkey/mozilla/accessible/src/base/nsRootAccessible.cpp  line 637]
   nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1697]
   nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp  line 1276]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3324]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3317]
   nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 4482]
   GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 794]
   nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp  line 3609]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1888]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsHTMLFormElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLFormElement.cpp 
line 736]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
   nsHTMLInputElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLInputElement.cpp 
line 1442]
   nsEventStateManager::SendFocusBlur
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 4248]
   nsEventStateManager::SetContentState
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3940]
   nsHTMLInputElement::SetFocus
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLInputElement.cpp 
line 1069]
   nsEventStateManager::ChangeFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2901]
   nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 1816]
   PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6326]
   PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6240]
   nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2223]
   nsView::HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 309]
   nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 1959]
   HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 83]
   nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1154]
   nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1171]
   nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5439]
   ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5694]
   nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 4190]
   nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1438]
   USER32.dll + 0x27ad7 (0x77d67ad7)
   USER32.dll + 0x2ccd4 (0x77d6ccd4)
   USER32.dll + 0x4455 (0x77d44455)
   USER32.dll + 0x95d5 (0x77d495d5)
   nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480]
   main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1287]
   main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1645]
   WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1666]
   WinMainCRTStartup()
   kernel32.dll + 0x214c7 (0x77e814c7)

    Source File: 
c:/builds/seamonkey/mozilla/accessible/src/base/nsAccessibilityService.cpp line
: 1444

   (19461206)      URL: www.gamestar.de
   (19415270)      URL: http://www.onlineglueck.de
   (19412278)      URL: www.livejournal.com/~geekmizztrezz
   (19412278) Comments: I clicked a check box on a poll.
   (19408436)      URL: www.hotmail.com
   (19399043)      URL: http://www.onlineglueck.de
   (19352646)      URL: vasoftware.com
   (19352646) Comments: checked a checkbox
   (19333912)      URL: www.hotmail.com
   (19333912) Comments: selecting check boxes
Keywords: qawanted
Summary: M130 topcrash [@ nsAccessibilityService::GetHTMLObjectAccessibleFor] → M140A crash [@ nsAccessibilityService::GetHTMLObjectAccessibleFor]
(Assignee)

Comment 6

15 years ago
This should no longer be a problem in the current trunk, since there is no
longer a GetHTMLObjectAccesibleFor() method. That code has been removed.

Should we mark it INVALID?

Comment 7

15 years ago
Yeah, looking at the latest Talkback data for the MozillaTrunk for the last 30
days, I don't see this crash in any builds other than the M140B release. 

I'm just going to mark this worksforme based on that and Aaron's last comment.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsAccessibilityService::GetHTMLObjectAccessibleFor]
You need to log in before you can comment on or make changes to this bug.