text files with formfeed characters display incorrectly

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: db48x, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
A formfeed-linefeed combination ("\x0c\0a") causes mozilla to display everything
up to the formfeed, then nothing. The scrollbars indicate a document that is
very long and very wide, but this is not the case. (see the url) The formfeed is
displayed as an empty box, which is fine.

A single formfeed ("\0c") does not cause the remaining text to dissapear, but it
does cause the scrollbars to go wacky.

I would expect it to simply ignore the formfeed, and possibly the linefeed.
Anything other than the current behavior is probably preferable.

I'm using the 1.4a branch build (2003040105) right now, but I've been seeing
this on the trunk for a couple of weeks.

A good source of example documents that hit this bug are the RFCs, such as
ftp://ftp.rfc-editor.org/in-notes/rfc1918.txt
This must be Windows-only?  I can't repro on Linux...
Whiteboard: DUPEME
Duplicate of bug 122937?

Comment 3

15 years ago
*** Bug 203156 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
I can't reproduce this with the 1.4a release (build 2003040105) on Windows NT 4,
but bug 203156 claims the same problem on Windows XP.
(Reporter)

Comment 5

15 years ago
it's gone away with build 2003050714, so I guess it got fixed along the way
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.