Inaccessible (access-controlled) stylesheet causes browser crash - Trunk M140A [@ nsHttpChannel::GetCallback]

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: Nathan Bailey, Assigned: dbaron)

Tracking

({crash, topcrash})

Trunk
PowerPC
Mac OS X
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401

http://polynate.net/crash.html kills the above Mozilla as well as my Camino
nightly (2003032705).  The base stylesheet is behind HTTP-auth protection.  The
page works fine in Moz1.3

Reproducible: Always

Steps to Reproduce:
1. Go to http://polynate.net/ with the above build
2. Browser crashes


Actual Results:  
Browser crashed and went to talkback form

Expected Results:  
Loaded the page, provided an HTTP-auth dialogue for the stylesheet, displayed
the page.
->Style System
Assignee: other → dbaron
Component: Layout → Style System
(Assignee)

Comment 2

15 years ago
The crash should be fixed by the checkin for bug 199910.  That still doesn't
solve the issue of prompting correctly, although there might be another bug on that.
Depends on: 199910

Comment 3

15 years ago
Confirmed using FizzillaMach/2003040103, crashing at nsHttpChannel::GetCallback
and generating TB222857Q.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: inaccessible (access-controlled) stylesheet causes browser crash → Inaccessible (access-controlled) stylesheet causes browser crash [@ nsHttpChannel::GetCallback]

Comment 4

15 years ago
Created attachment 119312 [details]
Crash report generated by FizzillaMach/2003040103 showing crash at nsHttpChannel::GetCallback

Comment 5

15 years ago
Adding Trunk and M140A to summary.  This *was* a topcrasher on the MozillaTrunk
and is a topcrasher with Mozilla 1.4 alpha.  It looks like this crash was indeed
fixed by the checkin for bug 199910.  There have not been any crashes on the
MozillaTrunk after 4/1 builds (4/1 also happens to be the build date for Mozilla
1.4 alpha...so that is why people are crashing with that milestone).

I'm going to mark this fixed based on the latest Talkback data.  For those that
are crashing, try a recent Mozilla nightly build...this crash should no longer
be happening with the latest builds.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: topcrash
Resolution: --- → FIXED
Summary: Inaccessible (access-controlled) stylesheet causes browser crash [@ nsHttpChannel::GetCallback] → Inaccessible (access-controlled) stylesheet causes browser crash - Trunk M140A [@ nsHttpChannel::GetCallback]

Comment 6

15 years ago
verified on macosX , linux and winXP platforms with latest nightlies.
No crash seen
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsHttpChannel::GetCallback]
You need to log in before you can comment on or make changes to this bug.