All users were logged out of Bugzilla on October 13th, 2018

Proxy: Switching to SSL page / authentication fails

RESOLVED DUPLICATE of bug 201054

Status

()

--
major
RESOLVED DUPLICATE of bug 201054
16 years ago
16 years ago

People

(Reporter: tschlabach, Assigned: darin.moz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

Switching from a non-SSL to a secure (SSL) page does not work when using a HTTP
proxy that required authentication.

Reproducible: Always

Steps to Reproduce:
1. Start the browser.
2. Get an environment with a proxy that required authentication and make sure
the proxy asks for authentication again when starting an SSL connection (i.e.
will not reuse the existing non-SSL proxy session.)
3. Bring up the non-SSL page. This will make Mozilla ask for the proxy username
and password.
3. Klick on a link on that page which points to a SSL page (like in many shops
when finishing the order)

Actual Results:  
The operation will time out leading you to believe the site was unavailable, but
it isn't. (Trying the very same with IE will lead to the proxy authentication
form popping up again and takes you to the site after supplying your credentials
once again.)

Expected Results:  
Either ask the user again to enter his/her proxy username/password OR reuse the
credentials entered before for the non-SSL session.
(Assignee)

Comment 1

16 years ago
normally, this works.  something must be odd about your configuration. 
reporter: can you please provide a mozilla HTTP log using the following steps:

open a DOS prompt and type:

C:\> set NSPR_LOG_MODULES=nsHttp:5
C:\> set NSPR_LOG_FILE=C:\log.txt

now, run mozilla from the DOS prompt (be sure Mozilla is not already running):

C:\> cd \path\to\mozilla
C:\path\to\mozilla\> .\mozilla.exe

now, go and reproduce the problem.  exit the browser.  finally, upload log.txt
to this bug report or feel free to email it to me directly.  thx!

Comment 2

16 years ago
Created attachment 120043 [details]
Log file of attempted NTLM proxy authentication with an SSL site.

I believe I have the same problem.  I'm using 1.4alpha1 with the new NTLM proxy
authentication feature.  This works well with ISA Server and normal HTTP;
however, when I try to use SSL, I get given a proxy authentication dialog, and
then nothing is displayed (current page remains displayed, that is).  I've
generated a log and uploaded it.
(Assignee)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 201054 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
The fix is in.

If it works, please mark this verified!
Summary: Switching to SSL page / proxy authentication fails → Proxy: Switching to SSL page / authentication fails
You need to log in before you can comment on or make changes to this bug.