Installing Mozilla 1.3 (final) causes Netscape 7.02 bookmarks file to be overwritten by Mozilla bookmarks file

RESOLVED INVALID

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Mark T. Chapman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I have been using both Netscape and Mozilla on my system since the first Mozilla
beta came out.  I recently upgraded Netscape 7.01 to 7.02 and all was fine.  A
few days later, I upgraded Mozilla from 1.3 (a or b, I don't recall) beta to the
final 1.3 build.  As a result, the bookmarks file from the Mozilla directory
overwrote the bookmarks file in the Netscape directory, causing me to lose many
bookmarks. (Both files have many of the same bookmarks, but many recently added
to the Netscape file didn't exist in the Mozilla file).  This is NOT a Netscape
problem, as all was working correctly until I installed Moozilla 1.3.

Reproducible: Didn't try

Steps to Reproduce:
1.Upgrade to Mozilla 1.3
2.
3.

Actual Results:  
As explained above.  The only way to reproduce it would be to reinstall Mozilla
1.3, and I don't know that it would happen on a reinstall anyway.  Perhaps it
only occurs when upgrading.

Expected Results:  
The mozilla bookmarks file should be completely separate from the Netscape file
and not affect it at all upon installation.

This can have serious repercussions for those using both Netscape and Mozilla. 
I was able to recover most of my bookmarks from a several month old backup of
the Netscape bookmarks file, but not all.
Netscape and Mozilla use the same profile and the same bookmarks unless you use
a seperate profile for Mozilla 8as the Mozilla release notes suggest).

And this is a Netscape bug because the current profile directory is :
application Data\Mozilla\......

Netscape should use application Data\Netscape..

Do you "simple" lost your bookmarks file with 1.3. Is this correct ?

Comment 2

14 years ago
Marking Invalid by example of bug 114983, and also due to age.  Please reopen
only if use of one browser causes problems in a profile ONLY used by the other
browser (this wasn't entirely clear in the report).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.