Closed Bug 200502 Opened 17 years ago Closed 17 years ago

"-splash" command-line option (and probably also others) causes URL argument to be ignored

Categories

(Core Graveyard :: Cmd-line Features, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 58523

People

(Reporter: JITR, Assigned: law)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (*; U; *; en-US; rv:1.2.1 & 1.3) Gecko/20021130 & Gecko/20030312

When the "-splash" option is specified as the last option on the command-line,
Mozilla ignores the following URL argument.

Reproducible: Always

Steps to Reproduce:
1. in Linux, make sure Mozilla's not running (not necessary in Windoze, because
running mozilla(.exe) again just opens another window)
2. execute "mozilla -splash http://www.mozilla.org/" - works as if no URL was
specified

Actual Results:  
Mozilla starts up as if "mozilla -splash" was executed, ie. it doesn't open the
URL specified.

Expected Results:  
Mozilla should open the URL specified the same way it does when "mozilla
http://www.mozilla.org/" is executed (this time, "-splash" was omitted). Well,
with the additional splash screen shown, which is not default in Linux. ;-)

The analysis shows the "-splash" option sometimes screws up the command-line
parsing process. (Please note this bug "works" both in Linux and Windoze (not
sure about other OSes), even when the "-splash" option has no effect in Windoze
as the splash screen is shown by default there (like it couldn't do the same in
Linux?).)

Separating the offending "-splash" option with other options (eg. "-width <arg>"
and/or "-height <arg>") fixed thigs alll right. That is, executing "mozilla
-splash -width 500 -height 500 http://www.mozilla.org/" works fine as if no
"-splash" was present (in the terms of the problems caused by the option, the
splash is, of course, shown as one might expect).

Other options might have the same effect, I can report the same bug being
caused, for example, by "-nosplash".

This might look like a dupe of the bug #58523. But the "effects" of both bugs
are different, even though their source might be similar if not the same.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 58523 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.