Flash plugin crashes - M17x FF10 [@ NPSWF32.dll][@ GetQDGlobalsBlack ][@ ntdll.dll - NPSWF32.dll][@ libflashplayer.so]

VERIFIED INVALID

Status

defect
--
critical
VERIFIED INVALID
16 years ago
3 years ago

People

(Reporter: tracy, Assigned: jst)

Tracking

({crash, topcrash+})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [upgrade to Flash 7], crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
seen with mozilla and commercial builds for 2003-04-03-03-trunk
(not happening on windows nor linux)

-create a new profile and launch that profile
-go to www.nytimes.com
crash

I normally hit this site in International Browser smoketest IB.4 using a
bookmark that I copy to a newly created profile. With that bookmark I had not
been seeing this crash.  However, today, I lost the bookmark file and had to hit
the page directly from the link in the smoketest page.  Crash.  So I back tested
only to discover that builds have been crashing at nytimes.com for at least a
month. :-(  Note the IB.4 smoketest requires switching View | Character Coding |
Auto Detect to Universal.  But it doesn't matter if it's set to that or set to
off.  Either way the crash still occurs.

Comment 2

16 years ago
exact same bug, but marked WFM: bug 197717.
Do you still crash after upgrading Flash plug-in too ?
Keywords: crash
Summary: Crash entering NY times → Crash entering NY times [@ GetQDGlobalsBlack ]
(Reporter)

Comment 3

16 years ago
marking invalid. sorry folks.  updating Flash on my system got rid of this
crash. But, shouldn't the browser catch the flash version and ask to update
instead of crashing?
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
You may want to reopen and move to Plug-ins to ask Peter ?
Component: Browser-General → Plug-ins
(Reporter)

Comment 5

16 years ago
Good suggestion Olivier.

Peter, should Mac have a way to catch cases like this and serve up a plugins
download dialog instead of crashing?   
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
.
Assignee: asa → peterlubczynski
Status: REOPENED → NEW
QA Contact: asa → bmartin

Comment 7

16 years ago
We've had lots of bugs similar to this. See:
Bug 119480
Bug 134350
Bug 197717

What version(s) of Flash crash or work correctly? I think we'd need some kind of
hack to catch this and direct the upgrade. 
Summary: Crash entering NY times [@ GetQDGlobalsBlack ] → [OSX]Older Flash causes crash entering NY times [@ GetQDGlobalsBlack ]
I believe everything before r67 was buggy. Maybe we just shouldn't load them?

Comment 9

16 years ago
*** Bug 203286 has been marked as a duplicate of this bug. ***
*** Bug 204633 has been marked as a duplicate of this bug. ***
*** Bug 207617 has been marked as a duplicate of this bug. ***
*** Bug 211230 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
I had this exact problem and was able to resolve it by ugradeing to the latest flash and 
shockwave plugins, however, what puzzles me is that the new flash plugin is exactly the
same as the old one.  

I was able to isolate the problem to 'NP-PPC-Dir-Shockwave' in the '/Library/Internet Plug-Ins'
directory - when I had that plugin in the 'Plug-Ins' directory www.nytimes.com crashed,
when I removed it it did not crash.

Im wondering if somehow its not the plugin, but some kind of plugin preferences causing the 
problem.
*** Bug 211831 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 209169 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 212194 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 210987 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 213113 has been marked as a duplicate of this bug. ***
*** Bug 212568 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
*** Bug 215438 has been marked as a duplicate of this bug. ***
*** Bug 215804 has been marked as a duplicate of this bug. ***
*** Bug 217019 has been marked as a duplicate of this bug. ***
We need to do something about this for 1.5.  It's gonna bite a lot of people and
crashing isn't the best way to inform the user to upgrade flash versions. 
Flags: blocking1.5b?
Flags: blocking1.5?

Updated

16 years ago
Flags: blocking1.5b?
Peter, do you have any cycles to look into this? Bryner, can you help?
Peter, do you have any cycles to look into this? Bryner, can you help? This at
the top of our topcrash list and would definitely be a good one to get for 1.5.
Flags: blocking1.5? → blocking1.5+

Comment 26

16 years ago
This is #2 top crash for all mozilla crash reports on all platforms.  be a good
one to nail...
The only thing we can do to fix this is to warn uers if they have an older Flash
version installed. We can't work around the crash at all.
Meaby blocking flash for those with old plugins?

Comment 29

16 years ago
We should probably do what Simon suggests in comment #8.

Some kind of check could be put into nsPluginsDirDarwin.cpp when we know the
version number for Flash.

There's also an ugly hack in nsPluginHostImpl::GetPluginFactory that can
probably be removed.

Comment 30

16 years ago
*** Bug 218481 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: topcrash
Peterl, can you help us with that check? 

Comment 32

16 years ago
*** Bug 219590 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
Ok, I finally found a Mac with 10.2.6, Flash 6.0 r29, and even a debug build of Seamonkey 1.5b 
from a few weeks ago but I'm not crashing at the nytimes.com nor with other top sites with Flash 
like disney.com, marcomedia.com, or hardrockhotel.com. 

Can someone please help me reproduce this problem by attaching a minimal testcase, their 
version of the  problem Flash plugin, and ensuring the problem still happens in daily builds? 
Thanks.
Whiteboard: [need help reproducing]
Peter, I can crash consistently by reloading my.netscape.com until a flash
banner ad comes up. I'm running Flash 6.0 r47 on Mac OS X 10.2.6 with the latest
1.5 branch build.
I can also reproduce by hitting a flash banner at my.netscape.com with the
latest trunk build.

Comment 36

16 years ago
ok, I see it in a 1.5 nightly. I'm making a build now. I wonder if it's just not
showing up in a debug build.
Whiteboard: [need help reproducing]
Peter, any progress? Is there anything I can do to help here?

Comment 38

16 years ago
yeah, ok, I see the problem even in my debug build from yesterday. Only certain
sites with Flash seems to crash. A simplified testcase would be very helpful to
explain why some sites crash and others do not.

I noticed Flash 7 doesn't crash but does not come pre-installed. Disabling the
Flash 6 plugin will create the need for everyone to download an upgrade if they
want Flash support, even if they weren't seeing this problem.
Whiteboard: [upgrade to Flash 7]

Comment 39

16 years ago
*** Bug 220013 has been marked as a duplicate of this bug. ***

Comment 40

16 years ago
peter: we don't have to do anything without the user's consent.  would you
object to a warning the first time a user with a an affected plugin tries to
download a .swf?  the warning could give the user the options of:
 1) continue anyway and risk crashes
 2) just move the bad plugin out of the way and not view flash content
 3) download a fixed plugin

the real solution, of course, is to make mozilla more tolerant of buggy plugins:
 bug 156493
but that's not happening before 1.5...

Comment 41

16 years ago
*** Bug 220973 has been marked as a duplicate of this bug. ***

Comment 42

16 years ago
*** Bug 221497 has been marked as a duplicate of this bug. ***
*** Bug 223136 has been marked as a duplicate of this bug. ***

Comment 44

16 years ago
nominating because this got blocking 1.5+ but wasn't fixed. Not sure of the
current status...
Flags: blocking1.6?

Updated

16 years ago
Flags: blocking1.6? → blocking1.6-

Comment 45

15 years ago
*** Bug 232635 has been marked as a duplicate of this bug. ***

Comment 46

15 years ago
Unable to reproduce this with the latest version of Mozilla & Flash Player 
(Mozilla 1.6 and Player 7). Confirmed on Win 2k/ XP/ Mac OX 10.3
Browsing VG.no <http://www.vg.no> today 2004.03.28 sets both Mozilla 1.7b as
well as Firefox 0.8 spinning, for instance when browsing exactly this page:
<http://www.vg.no/pub/vgart.hbs?artid=221109>. Firefox starts spinning a little
bit later than Mozilla (i.e. I can work a little longer with Firefox than with
Mozilla). The sample page makes heavy use of Flash. I am on OSX 10.3.3 and the
Flash player is 7.0 r14. Don't know if it is the same bug. No problems in Safari.

Comment 48

15 years ago
leif: 7.0 r14 doesn't suffer from this bug.  you ought to open a new one.

Comment 49

15 years ago
*** Bug 202968 has been marked as a duplicate of this bug. ***

Comment 50

15 years ago
There are a lot of crashes related to older Flash plugins on all platforms. 
Changing OS to All and updating summary with Talkback info for tracking.  This
continues to be a topcrasher for Mozilla 1.7 and Firefox 0.9.x.
OS: MacOS X → All
Hardware: Macintosh → All
Summary: [OSX]Older Flash causes crash entering NY times [@ GetQDGlobalsBlack ] → Older Flash causes crash entering NY times - M17 FF092 [@ GetQDGlobalsBlack ][@ NPSWF32.dll]

Comment 51

15 years ago
Adding relnote keyword.  We should tell users to upgrade to the latest version
of Flash to avoid this crash.
Keywords: relnote

Comment 52

15 years ago
*** Bug 243357 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: Older Flash causes crash entering NY times - M17 FF092 [@ GetQDGlobalsBlack ][@ NPSWF32.dll] → Older Flash causes crash entering NY times - M18a2 FF09x [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so]

Updated

15 years ago
Depends on: 211213
added a relnote
Keywords: relnote

Updated

15 years ago
Summary: Older Flash causes crash entering NY times - M18a2 FF09x [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so] → Older Flash causes crash entering NY times - M17x FF10PR1 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so]

Updated

15 years ago
Summary: Older Flash causes crash entering NY times - M17x FF10PR1 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so] → Older Flash causes crash entering NY times - M17x FF10RC2 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so]

Comment 54

15 years ago
Still a topcrasher for Firefox 1.0.  

It'll be nice to find out if users that have upgraded to Flash 7 are still
seeing this crash.  If anyone can still reproduce, please report back with your
version.
Summary: Older Flash causes crash entering NY times - M17x FF10RC2 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so] → Older Flash causes crash entering NY times - M17x FF10 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so]
Marc Bejarano claimed I had to open a new bug. Perhaps I misunderstand but now
we are asked about Flash 7.

I have Flash 7. The two top (in hits, not quality) news sites, www.vg.no and
www.dagbladet.no have become completely framed by flash animations. So much that
have complained to Dagbladet.no about since they, after all, recommened Firefox.
And why recommend a Firefox when it cannot handle their own web site's animations?

So yes, it still crashes. But somehow it as become better. I takes longer time
before it crashes. But it still crashes. And it hogs the system, uses a lot of
processor power. I check it in the termnail, in the top command. I freequently
closes pages that gets my machine (PowerBook G4 from 2004 with 1,2 GB ram) «work
hard».

Comment 56

15 years ago
leif: are you really crashing, or just hanging?  this bug was about the whole
browser crashing and the reproducible test cases i had were fixed by upgrading
the version of flash.  i'm not surprised this is still a top crasher.  i think
comment 29 is still the way to go.

Comment 57

15 years ago
Peterl has not chimed in for a while, reassigning to jst in case he can help.  
If there is anyone else that can work on this, please reassign again.
Assignee: peterlubczynski-bugs → jst

Comment 58

14 years ago
*** Bug 279114 has been marked as a duplicate of this bug. ***

Comment 59

14 years ago
*** Bug 269452 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Summary: Older Flash causes crash entering NY times - M17x FF10 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so] → Flash plugin crashes - M17x FF10 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so]

Comment 60

14 years ago
Flash 7.0 r19 still crashes with the 2005-01-20 Win32 build of Mozilla (I
haven't checked it with the 01-24 build yet, and I'm downloading a large file
right now) at sinfest.net and other Keenspot comics (see bug 279114 for a local
version of the page, a network trace and a Talkback ID)
(Reporter)

Comment 61

14 years ago
fwiw this wfm with a clean profile, flash 7.0 r19 installed post mozilla
install. I tested with sites here and several duped bugs.  no crash as seen with
Windows Mozilla build 2005-01-25-07-trunk on Win XP sp2

Updated

14 years ago
Keywords: topcrashtopcrash+
Summary: Flash plugin crashes - M17x FF10 [@ GetQDGlobalsBlack ][@ NPSWF32.dll][@ libflashplayer.so] → Flash plugin crashes - M17x FF10 [@ NPSWF32.dll][@ GetQDGlobalsBlack ][@ ntdll.dll - NPSWF32.dll][@ libflashplayer.so]

Comment 62

14 years ago
*** Bug 279789 has been marked as a duplicate of this bug. ***

Comment 63

14 years ago
WFM on latest branch. Perhaps original reporter can try a newer one.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050818
Firefox/1.0+

Comment 64

14 years ago
downgrade your flash player if you want to feel the pain everybody is talking
about ;)

Comment 65

14 years ago
(In reply to comment #64)
> downgrade your flash player if you want to feel the pain everybody is talking
> about ;)

No thanks. Is there any good reason for "downgrading" in this case?

Comment 66

14 years ago
the only reason would be for you to reproduce the crash.  you said WFM and
there's a reason for that.  anyway, we should knock this off.  the 47 cc's
probably aren't enjoying this as much as we are :(

Comment 67

14 years ago
In that case, the bug should just be marked as invalid or WONTFIX with a final
recommendation to update flash. Unfortunately, it won't allow me to mark it. So...

Comment 68

14 years ago
the status whiteboard already says what it need to.  leaving this bug open means
that more people find it.  and some day, the bug will be fixed.  firefox
shouldn't crash.  see bug 156493.
Depends on: 156493

Comment 69

13 years ago
we could include flash instiller in firefox update this would stop this crash and fix some of the security bugs (make it only install if you use old version
*** Bug 353014 has been marked as a duplicate of this bug. ***
*** Bug 285837 has been marked as a duplicate of this bug. ***
*** Bug 334501 has been marked as a duplicate of this bug. ***
*** Bug 347890 has been marked as a duplicate of this bug. ***
*** Bug 353100 has been marked as a duplicate of this bug. ***
*** Bug 346428 has been marked as a duplicate of this bug. ***
*** Bug 348211 has been marked as a duplicate of this bug. ***
Before some hours I duped some Flash crasher bugs to this one. It seems that the crash also appears for newer Flash versions as 7. The top stack frame is mostly NPSWF32.dll or libflashplayer.so.

I'm not definitely sure if that was the right decision. How should we deal with these bugs? Duping or better not? If we dupe them we should update the whiteboard accordingly. Any idea?

Comment 78

13 years ago
it depends on what we're trying to track with this bug.  i thought we were just tracking the particular flash bug in pre-r67 releases that nytimes.com et al were tickling.  some of the bugs you just duped are definitely different bugs in flash because people are using newer versions.  i say we undupe the recent ones and get some adobe folks to look into the newer reproducible crashes and then dupe appropriately.  any objections?

Comment 79

13 years ago
If there are valid crashes that you see with the current Flash Player (9r16 or higher), then please let us (Adobe Flash Player team) know, either with this bug or by filing new bugs, and adding me as a cc:. Thanks.

Comment 80

13 years ago
I have the problem in Seamonkey 1.0.5 on Linux x64 with a npwrapped Flash 7-plugin. Downgrading to 1.0.4 solves the problem.

Comment 81

13 years ago
(In reply to comment #80)
> I have the problem in Seamonkey 1.0.5 on Linux x64 with a npwrapped Flash
> 7-plugin. Downgrading to 1.0.4 solves the problem.
> 
I can comfirm the same problem using Firefox 1.5.0.7 on Ubuntu Dapper 6.06 x64 using nspluginwrapper. Flash 7 no longer loads. It can also cause a lock-up when using the embedded browser inside Liferea.

Problem only appeared with the recent Ubuntu upgrade from 1.5.0.6 to 1.5.0.7.

Comment 82

13 years ago
(In reply to comment #79)
> If there are valid crashes that you see with the current Flash Player (9r16 or
> higher), then please let us (Adobe Flash Player team) know, either with this
> bug or by filing new bugs, and adding me as a cc:. Thanks.

Shockwave Flash 9.0 d55

Details - talkback ids: 25901486, 25901765, 25901768

Comment 83

13 years ago
ok.  i unduped the non-dupes.

willem: please file a new bug for what you described in comment #80 and cc myself, michelle, marjorie, and hubert.

i'll mark this as invalid since it ended up being a bug in the flash player which has been fixed by the developer.
Status: NEW → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED

Updated

11 years ago
No longer depends on: 156493

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Flags: blocking1.6-
Flags: blocking1.5+
Product: Core → Plugins
QA Contact: bmartin → adobe-flash
Version: Trunk → unspecified

Updated

9 years ago
Target Milestone: --- → 2003
Version: unspecified → 6.x

Updated

9 years ago
Target Milestone: 2003 → 2004
Crash Signature: [@ NPSWF32.dll] [@ GetQDGlobalsBlack ] [@ ntdll.dll - NPSWF32.dll] [@ libflashplayer.so]

Comment 84

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2004 → ---
Version: 6.x → unspecified
You need to log in before you can comment on or make changes to this bug.