If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

textarea and -moz-opacity break up and down arrow keys

RESOLVED WORKSFORME

Status

()

Core
Selection
--
minor
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Max Kanat-Alexander, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
This is a rather funny bug.

I've noticed this in both 1.2.1 MacOS-X and 1.3 Win2K.

Steps to reproduce:
1) Create a textarea, and give it a -moz-opacity value less than 1. (Either
standards-compliant-mode or quirks mode, doesn't matter.)
2) Type the following lines in exactly the following fashion:
aaaaaaa
aaa

a
3) Go down to the single "a." Try to use the up-arrow to move up to the previous
line. (It will fail.)
4) Go to the first line, and place the text cursor after the second "a." Press
the down-arrow key. (It will work.)
5) Go to the end of the first line, press the down-arrow key. (It should fail.)

Expected Results:
The text cursor will move up and down appropriately, as though it was a "normal"
textarea.

Actual Results:
Basically, opacity makes it so that the text cursor can no longer move into
empty areas.

I have noticed the behavior on MacOS X and Windows 2000. That's enough for me to
label it "all." 

This may be somehow related to bug 155316 and bug 129981.

I've put it as being in the GFX component, because that seems like the closest
to what would be correct.

It seems pretty minor, but it might be a symptom of some larger problem. 

-M
(Reporter)

Comment 1

15 years ago
Created attachment 119336 [details]
Reduced Testcase

Here's a very reduced testcase to run the "steps to reproduce" on.

-M
(Reporter)

Comment 2

15 years ago
Amendment to Step #3:

You must move the cursor to the end of the line after the single "a," and _then_
try to move teh cursor up.

-M
To jfrancis.
Assignee: kmcclusk → jfrancis
Component: GFX → Editor: Core
QA Contact: ian → sairuh

Comment 4

15 years ago
I think this is a selection issue; cc aaronl since he may be able to fix.
I noticed that -moz-opacity on a span or div will also affect arrowing up/down
if the lines are not the same length.  I'd guess this affects caret browsing too.
Assignee: jfrancis → mjudge
Component: Editor: Core → Selection
QA Contact: sairuh → pmac

Comment 5

14 years ago
Created attachment 131168 [details]
testcase
Assignee: mjudge → selection

Comment 6

14 years ago
Dont know if I understood everything correctly but i followed the steps in
comment 0 and this WFM, build 20031202 , Windows XP
(Reporter)

Comment 7

14 years ago
I can't even check the testcase in Firebird 0.7 / Linux (Fedora Core 1) because
the moz-opacity seems to now make the textarea disappear.

I'm assuming this is due to another bug that I haven't searched for.

-M 

Comment 8

13 years ago
WFM in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040720

WFM in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040720
Firefox/0.9.1+

Following reporter's steps, I cannot reproduce the buggy results.  The cursor
moves appropriately.  I recommend a chaneg in status/resolution (WFM or Fixed?).
(Reporter)

Comment 9

13 years ago
Yep, guess it was fixed somewhere along the way.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.