Browser returns first button as default button when no button is selected on 'One Text Box' html pages.

RESOLVED DUPLICATE of bug 156683

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 156683
15 years ago
14 years ago

People

(Reporter: Amar Chokhawala, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

If I have a page with one text box and two html buttons and I press enter on
text box, browser submits value of first html button. On mozilla 1.2 or earlier,
it used to return null.

Reproducible: Always

Steps to Reproduce:
1.Create html page with one text box and two html buttons with same name and
different values
2. When you press enter on text box, browser does submit thats ok.
3. But in your server side the value for button will be value of first button
not null.

Actual Results:  
But in your server side the value for button will be value of first button not null.

Expected Results:  
Mozilla should return null value, not value of first button.
And if you have two textboxes it's ok to submit one of the buttons?  ;)

*** This bug has been marked as a duplicate of 156683 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.