Want the ability to duplicate tabs

RESOLVED DUPLICATE of bug 18808

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 18808
15 years ago
4 years ago

People

(Reporter: nrlz, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Sometimes I'm reading a site and want to refer to two section of the page at the
same time, so I open another Tab at the same URL.

There is no supported way to do this other than to open a new Tab and
copy/paste/drag/drop the URL from another Tab.

I want the ability to duplicate a Tab which loads the same page (and possibly
the same content including any filled out forms). It is best if the option is
put on the context-menu (right-click menu) which says "Duplicate Tab".

Reproducible: Always

Steps to Reproduce:



Expected Results:  
Add a menu option "Duplicate Tab" to the context-menu of the current tab.

Comment 1

15 years ago
You can already do this in several ways:

1. Go to the URL and hit Ctrl Enter.
2. Drag and drop the proxy icon (to the left of the URL text) to the tab bar.

Are these sufficient or do you have to have a menu option?  (Which will probably
get marked WONTFIX.)  If the workarounds are okay, please resolve this bug as
WORKSFORME.
There's already a bug report asking for this feature....
Whiteboard: DUPEME
(Reporter)

Comment 3

15 years ago
Option 1: (Ctrl+Enter) will open the page in a new window on my system; not a
new Tab. (maybe it's just my settings. dunno)
Option 2: is what I am currently using but I would like to see a menu item
because it is quicker. Using the proxy icon drag technique takes 3 steps. (a)
New Tab; (b) Switch back to old Tab; (c) Drag proxy icon; I hope to achieve this
in 1 step.

If this is a duplicate request, could someone post the id?

Comment 4

15 years ago
According to bug 194178, comment #1 there are several bugs about this issue.
Can we agree upon marking this as dupe of one of them?
(Reporter)

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.