Closed Bug 200624 Opened 17 years ago Closed 17 years ago

Links overlapped by <object> unclickable

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 102695

People

(Reporter: ts, Unassigned)

References

()

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401 Phoenix/0.5

When going to the attached URL... 
The Ad, which is a layer, blocks any interaction with the page. 
I know gecko has a policy on layers, but this is blocking use of the page.
The layer on the page is reprecented by a white box (misaligned compared to IE).

Reproducible: Always

Steps to Reproduce:
1. go to URL
2. Try and click or select the text in the news, like the "Breed demo endnu
en..." news
Actual Results:  
I am unable to click or interact with portions of the site

Expected Results:  
It should be possible to work with the page regardless of the layer
Not Phoenix specific.
Component: General → Layout
Product: Phoenix → Browser
Version: unspecified → Trunk
Reassigning to default module owner
Assignee: blaker → other
QA Contact: asa → ian
I might be wrong here, but the ad seems to be a flash movie inside two div:s.
One is absoluteley positioned and has id="Layer1". So it doesn't seems to be a
"layer-tag" issue.

I just wonder where the ad should be, tried with three different browser on my
mac (NS 4.5, IE 5.1 and Mozilla 1.2.1) and it ends up in different places.

There might be something wrong with the page code here.



You might be right about the DIV tags, it apears correctly in IE 6.1, in the
center whereafter it disappears after a few seconds of advertising (or atleast
allows users to interact with the content below the ad)


After re-checking the HTML code I can also see that the site is poorly coded, it
has more than one <body> tag (I counted 3 so far)... it is, however, displayed
"correctly" in IE... the only thing that bugs me is the fact that the ad does
not disappear and leaves the content below blocked from interaction

perhaps it is the position:absolute; top:200; width:100%; height:422px;
z-index:1 that causes problems, or atleast the position:absolute; part

as I read it... it is to be placed in the center table, 200 from the top and
with a width so that it extends the whole content table.

I was thinking Gecko is calculating the position based on another reference,
like another table... I don't really know :)

I'll try and get the webmaster to review this bug
> position:absolute; top:200; 

That means "200px from the top of the nearest absolute containing block." 
Absolute containing blocks are things with position:absolute, position:fixed,
position:relative, or the viewport.  A random table is not an absolute
containing block...
If that is the correct W3C way of parsing it, then I wonder if that is how IE
reads it?! 
Hmm, went thru the page. 10 <body> and 6 </body>... This is confusing, I wonder
how the page is rendered at all...

Below is the code with the ad: Note that there is a lot of code *above*, it's
like  4 <body> filled with tables etc etc.

<body text=black vLink=#990000 link=#990000 bgColor=#dddddd leftMargin=0 
topMargin=0>
<div id="Layer1" style="position:absolute; top:200; width:100%; height:422px;
z-index:1">   <div align="center">     <object
classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0"
width="470" height="366">
      <param name="movie"
value="http://www.gamereactor.net/easyads/banners/primal-popup.swf ">
      <param name="quality" value="high"> <param NAME=wmode VALUE=transparent>
      <embed src="http://www.gamereactor.net/easyads/banners/primal-popup.swf "
quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" width="470" height="366"></embed></object>


  </div>
</div>
Attached file testcase (obsolete) —
take look at green "anchor" and the green box. For some reason, Mozilla
take width:100% w/ respect to the page instead of the anchor container.
my last comment is bug 51230
the original complaint is either bug 102695 or INVALID
Summary: Layer causes unclickable pages → Links overlapped by <object> unclickable
It's clearly a bug, I'm not sure if it is related to Bug #102695

at best it might be a dup. of Bug #51230
Attached file minimal testcase (obsolete) —
the area inside the green bordered <div> is insensitive to left-click ("foo"
links don't work), even outside the <embed>.  right click seems to work fine.
Attachment #119550 - Attachment is obsolete: true
Attached file real minimal testcase
argh, this has nothing to do with object/embed...
Attachment #120265 - Attachment is obsolete: true
> the original complaint is either bug 102695 or INVALID

indeed.
marking dupe of 'Treat some transparent elements as "transparent to events"'

this was reported to Evang as bug 198225

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.