query gives 0 reports with WIN (IE6 and N7.0.1) but plenty with SuSE8.1 konqueror

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
--
trivial
RESOLVED INVALID
15 years ago
6 years ago

People

(Reporter: Matthias Lüttgert, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01

Bugzilla is running on a SuSE 8.1 Linux.
After http login, bugzilla 2.16.2 with activated groups gives access to the
bug reports using (SuSE Linux 8.1) konqueror.
Using Linux/Netscape7.0.1 or M$-Windows with IE6 or Netscape 7.0.1
(enabled all cookies): After login into the same account bugzilla gives
no access to the bugs, but displays, that I am logged in.
This behaviour occurs using the query machanism.
If in the same session an existing bug number is entered,
the access is denied and the user is logged out.
If a re-login is done, the single bug can be accessed and the user is
logged in. Accessing another bug by number or using the query form, the
login state is lost again and access is denied again.
It was tried the same server with the same IP from the same client
with the same client IP (multi-boot-system).
This behaviour did not depend on using a proxy. Even on direct
connection it occurs.

Reproducible: Always

Steps to Reproduce:
1. Install bugzilla 2.16.2 under SuSE Linux 8.1
2. Install german template 2.16.2RC
3. Use Apache/1.3.26 (Linux/SuSE) mod_perl/1.27
4. Activate groups in parameter settings
5. Create bug reports with SuSE Linux 8.1 konqueror
6. Query them using konqueror on any client: success
7. Try the same with Netscape 7.0.1 on any client: No bug reports
8. Try with IE6 on any client: No bug reports

Actual Results:  
I was frustrated and entered a bug report for bugzilla.

Expected Results:  
It should have remembered my login state (and give me access to the bug reports).

Tried with and without using proxy server (squid). Same result.
what are the contents of your urlbase and cookiepath parameters?
(Reporter)

Comment 2

15 years ago
This is in our LAN (not accessible via Internet):
urlbase: http://cvsrisa.risa.de/bugzilla/
cookiepath: /srv/www/htdocs/bugzilla
Your cookiepath is incorrect.  Set it to "/bugzilla/" and your problem will go
away.  The cookiepath is set to the user's web browser to instruct it which
directories in the website it is allowed to return the cookies to.  The browser
only knows what's after your docroot.  With the cookiepath that you set, it
would have only sent the cookies back if you visited
http://cvsrisa.risa.de/srv/www/htdocs/bugzilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Severity: major → trivial
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.