insert ">" character on text/plain attachments at the beginning of phrases that start with "From"

VERIFIED DUPLICATE of bug 121947

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 121947
15 years ago
10 years ago

People

(Reporter: Jordi Cucurull Juan, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ca; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ca; rv:1.3) Gecko/20030313

When a plain text file is attached to an email and this includes phrases that
starts with the "From" word, therefore the Mail&News application attachs the
file with the ">" character in front of that word. This is an important problem
specially when you're trying to attach a Tex file that contains the "From" word
by all the file.

Reproducible: Always

Steps to Reproduce:
1.Make a text file that includes at the beginning of any line the "From"
(without comilles) word (I've tryied with "vi" editor).
2.Attach the file to an email and just press "Save" button.
3.Look at the Draft folder and open the attached file, you will see the text how
I explained.

Actual Results:  
I've attached a file with that text:

From prova
From prova
From prova

After that, when I've opened this file in my draft email (the same it happens if
you send the email) the text was:

>From prova
>From prova
>From prova



Expected Results:  
Mozilla have not to modify my text file attachment.

There isn't any relevant information, only that I tryied it with Mozilla 1.0.1
for Linux, Mozilla 1.3 for Linux and for Windows ant the problem it's the same.
(Reporter)

Comment 1

15 years ago
Created attachment 119437 [details]
Text file and mail with the text file attached

This is a ZIP with the text file that fails to be attached and the email with
that file attached.

Comment 2

15 years ago
Sorry, but this is actually normal, to make sure that the 'From' isn't
recognized as a header. All mail clients do that, unless that mail is contained
inside a MIME-attachment (yes, Outlook too !). It's "just one of these things".
See for instance bug 33712.

Now, what we would need to do is to hide this from the user. See bug 121947.

*** This bug has been marked as a duplicate of 121947 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.