Closed Bug 200663 Opened 19 years ago Closed 17 years ago

delete key no longer removes item from download manager list

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 198247

People

(Reporter: mbokil, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

The delete key used to remove items from the download manager list without
having to click on remove item from list. 

Reproducible: Always

Steps to Reproduce:
1. Open download manager
2. High light item to delete
3. Press delete key

Actual Results:  
nothing, no visual change in download manager list.

Expected Results:  
item should have been deleted
Confirmed on 1.3 Release on Win98SE.
I see the same problem with 1.5a on OSF1 unix.
This seems to be a recent regression.
Error message in java console when I try to delete an item:
Error: ds.beginUpdateBatch is not a function
Source File: chrome://communicator/content/downloadmanager/downloadmanager.js
Line: 2690
I think the 'xxxBatchUpdate' functions were renamed to onBeginUpdateBatch and
onEndUpdateBatch in a recent update.
Case 173370 comment 2 pointed me in the right direction to find this error.

I have not had any problems deleting download entries until about one week ago.
comment 4 analysis wrong.
Nightly build 2003-05-17-08-trunk does not have this problem.
I am building additional nightlies to see where the problem starts.

*** This bug has been marked as a duplicate of 201697 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Bug 201697, which this bug has been marked as a duplicate of, is indeed fixed,
but this bug is not fixed. Or it has re-appeared again! 

The keybord delete button does not work. Tested win2k/classic using the latest
nightly build. (2003072104).
This bug should be re-opened. This bug is still here and it is not a duplicate
of the mentioned bug.
Works for me, DEC, OSF1
Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.5b) Gecko/20030724
Product: Browser → Seamonkey
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 198247 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.