cannot select text in the middle of pre-selected text in address bar

RESOLVED DUPLICATE of bug 177973

Status

SeaMonkey
Location Bar
RESOLVED DUPLICATE of bug 177973
15 years ago
10 years ago

People

(Reporter: Victor Chan, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030403 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030403 Phoenix/0.5

When I type an address in the address bar, example "http://www.mozilla.org",
normally when I click on it it selects the whole URL, but a bug in the address
bar keeps me from selecting part of the address, let say "zilla" (when I drag
around the word zilla, the active selection don't change, still
"http://www.mozilla.org"), same bug applies when I selected let say
"mozilla.org" and wish to change the selection to "illa.org"

Reproducible: Always

Steps to Reproduce:
1.Type http://www.mozilla.org into the address bar
2.Click somewhere else
3.Click on the address bar
4.Try to select part of the address in the address bar

Actual Results:  
The bug mentioned above re-produced, cannot select the partial address I wish to
select.

Expected Results:  
Change the way the address bar work into like what notepad in Windows work, easy
selection of text without the word grouping "feature".

Comment 1

15 years ago
The fact that when you click on the address bar's present address and that it is
totally selected should stay the same. 

What is bothering is that 'once it IS selected', with ONE click'n'drag inside
the already selected text you should be able to create a new selection, which
does not work at present.

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.6) Gecko/20040113

I found that if Keywords is enable (Preferences >>Smart Browsing >> Enable
Keywords) is impossible to select a part of the address. But with Keywords
disable the address bar behaviour is OK.



Comment 3

14 years ago
Hi

I change my version of autoscroll plugin (autoscroll.mozdev.org). And then the
Keywords state don´t produce the effect.

Victor Chan, have you got the autoscroll plugin install? Confirm if this plugin
cause this effect, please.

Comment 4

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040412 
and 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040411 Firefox/0.8


dupe of bug 177973

*** This bug has been marked as a duplicate of 177973 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.