build is not correctly set as official, debug menus exist

VERIFIED INVALID

Status

SeaMonkey
Build Config
--
major
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: Ken Tossell, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Trunk
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4a) Gecko/20030403
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4a) Gecko/20030403

Building the 1.4a release on PPC, with MOZILLA_OFFICIAL and BUILD_OFFICIAL set,
and the .mozconfig set as below, the Debug and QA menus show up, and the Build
ID is displayed in the menubar. The build system appears to ignore the
.mozconfig and environment variables.

.mozconfig:
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --without-system-nspr
ac_add_options --without-system-zlib
ac_add_options --without-system-jpeg
ac_add_options --without-system-png
ac_add_options --without-system-mng
ac_add_options --enable-crypto

I built exactly as I have for 1.3.

Reproducible: Always

Steps to Reproduce:
1. Follow http://www.mozilla.org/build/distribution.html

Actual Results:  
No errors; compiles and starts with problematic environment.

Expected Results:  
Compiled an "official" binary distribution.

Linux/PPC 2.4.20 -- Gentoo Current
>Debug and QA menus show up

Yes, but that's correct -> invalid
(an offical Build doesn't remove that)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.