[history tab] Quick search fails to find pags in history with Hebrew titles

VERIFIED FIXED in Firebird0.7

Status

()

--
major
VERIFIED FIXED
16 years ago
11 years ago

People

(Reporter: xslf, Assigned: bryner)

Tracking

({intl})

unspecified
Firebird0.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030402 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030402 Phoenix/0.5

Quick search fails to find pags in history with Hebrew titles- althugh they are
clearly there.

Reproducible: Always

Steps to Reproduce:
1. go to a few pages which have Hebrew titles.
For example:
http://www.haayal.co.il/
http://www.mozilla.org.il/board/viewforum.php?f=9
http://kinneret.miloberi.com/
http://www.exego.net/arspoetic/108.asp
2. Open the history sidebar, and enter in the search one of the Hebrew words
that appeared in the titles


Actual Results:  
Nothing is found

Expected Results:  
It should find one of the pages with the Hebrew titles

The quick search works fine for Bookmarks with Hebrew titles.

*** This bug has been marked as a duplicate of 180674 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
this bug is NOT about google search, but about the search in teh history tab,
which has nothing to do with google.
Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

16 years ago
updating title to make this bug more clear
Summary: Quick search fails to find pags in history with Hebrew titles → [history tab] Quick search fails to find pags in history with Hebrew titles

Comment 4

16 years ago
It doesn't work the Japanese language either.

*** This bug has been marked as a duplicate of 128634 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

16 years ago
wonder why my search didn't bring it up?
Status: RESOLVED → VERIFIED

Comment 6

16 years ago
Reopening as this bug still exist
(bug 128634 has been fixed).
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

16 years ago
Reassign to bryner
Assignee: blaker → bryner
Status: REOPENED → NEW

Comment 8

16 years ago
Created attachment 125688 [details] [diff] [review]
porting bug 128634 fix to Mozilla Firebird

bug 128634's patch has fixed only mozilla.
This is Mozilla Firebird version of the patch.

Updated

16 years ago
Severity: normal → major
Keywords: intl
OS: Windows 2000 → All
Hardware: PC → All

Comment 9

16 years ago
Comment on attachment 125688 [details] [diff] [review]
porting bug 128634 fix to Mozilla Firebird

oops. sorry, I've taken "bug 206775" for "bug 128634" in comment 8.
Attachment #125688 - Flags: review?(bryner)
(Assignee)

Comment 10

16 years ago
Comment on attachment 125688 [details] [diff] [review]
porting bug 128634 fix to Mozilla Firebird

r=bryner
Attachment #125688 - Flags: review?(bryner) → review+
(Assignee)

Comment 11

16 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
v.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Phoenix0.7

Updated

11 years ago
Component: History → Bookmarks & History
QA Contact: asa → bookmarks
You need to log in before you can comment on or make changes to this bug.