Mozilla does not display numeration when padding-left:0Px is specified for an <ol>

RESOLVED DUPLICATE of bug 128060

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 128060
15 years ago
15 years ago

People

(Reporter: Thomas Klaemmt, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

If you have someting like...
   <ol style="padding-left:0px;">
    <li> Item 1</li>
    <li> Item 2</li>
    <li> Item 3</li>
   </ol>
on your page, mozilla does not display the numeration and if you have something
like...
   <table cellpadding="10" cellspacing="0" border="1"> 
    <tr>
     <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
     <td>
      <ol style="padding-left:0px;">
       <li> Item 1</li>
       <li> Item 2</li>
       <li> Item 3</li>
      </ol>
     </td>
    </tr>
   </table>
on your page the list even exceeds the cell borders!

Reproducible: Always

Steps to Reproduce:
see URL
Actual Results:  
see URL

Expected Results:  
Mozilla should display the numeration aligned to left and of course it should
not exceed the cell borders!
(Assignee)

Comment 1

15 years ago
See bug 2038 and bug 128060 comment 10.

*** This bug has been marked as a duplicate of 128060 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Please correct me if I am wrong, but I don´t belive that this is a dup of 128060
because of 2 reasons:

1. AFAIK Bug 128060 is about the difference between padding and margin. My bug
is espacially about an incorrect way mozilla interpretates padding.
If I have a table with a list inside Mozilla must not "break" the borders of the
cell where it is coded in even if it would have been better to use a margin than
a padding.

2. It seems to me that mozilla "overwrites" the number generated by the <li>.
This should also not happen, when you use a padding-left:0. Because using the
padding-parameter on a OL-Tag is IMHO a valid usage of padding according to the
CSS2-Specs.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

15 years ago
No, it is a duplicate.

IE specifies the default indentation using margin, which is bad (see bug 2038).
 We specify it using padding.  If you set padding to zero, that un-indents the
UL in Mozilla, but not in IE.  You should specify both padding and margin.

*** This bug has been marked as a duplicate of 128060 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
See http://devedge.netscape.com/viewsource/2002/list-indent/ for a more detailed
exploration of this topic.
You need to log in before you can comment on or make changes to this bug.