File|New Message: pre-choose identity based on folder pane selection not working

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
P3
major
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 1999112409M12: Win32/NT4, Linux/Redhat 6.0, Mac 8.5.1

Overview: Using multiple accounts, the File|New Message option does not
pre-choose the identity based on the folder pane selection:

Steps to reproduce:
1. Start Mail with a profile using multiple accounts.
2. Select an account in the folder pane
3. Select File|New Message so the Compose window launches.

Actual Results: In the Compose From: field notice that the identity is always
the first account.
Expected Results: The From: field should reflect the identity of the account
selected in the folder pane.

Additional Information:
1. Using the "New Msg" button recognizes the correct identity. This was a
problem before but was fixed (Bug# 16821)
(Reporter)

Updated

19 years ago
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

19 years ago
Setting QA Contact to nbaca, adding lchiang to Cc: list.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
adding sspitzer and ducarroz to the CC, because I think one of them was poking
at this recently

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 3

19 years ago
Works for me
(Reporter)

Comment 4

19 years ago
Using the 11/30 Windows build when I select File|New Message it's always
displaying the first identity instead of recognizing the account I have
selected. It works if I select the "New Msg" button but not if I use the File
menu.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 5

19 years ago
reopen per ninoschka's findings.
(Assignee)

Updated

19 years ago
Target Milestone: M13
(Assignee)

Comment 6

19 years ago
since this is just the case of the menu, I'm moving this to m13.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 7

19 years ago
oh my, this is a much more difficult thing than I ever imagined.
the menu items for composing a message come from the global overlay, which has
it's own goofy compose-window-opening routine.
We need to consolidate this. I'll talk to hangas about this tomorrow.
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 8

19 years ago
moving M13 bugs to M14 to get them off the radar.
(Not to worry, I'm still working on these before my other m13 bugs!)

Comment 9

19 years ago
It works ok from the toolbar, but not from the File menu. Seems ok for B1.
Target Milestone: M14 → M15
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M16
(Assignee)

Comment 10

18 years ago
moving non-critical bugs to M20
Target Milestone: M16 → M20
(Assignee)

Comment 11

18 years ago
seems to work now, I think varada fixed this.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

18 years ago
Branch build 2000-10-24-09MN6: NT4, Linux 6.0, Mac 9.04
Verified Worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.