new XMLSerializer().serializeToString(document.documentElement) lacks markup of the documentElement

RESOLVED DUPLICATE of bug 186554

Status

()

Core
XML
RESOLVED DUPLICATE of bug 186554
15 years ago
15 years ago

People

(Reporter: Martin Honnen, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
When passing the documentElement of an HTML or XML document to new
XMLSerializer().serializeToString the result is only the "inner" XML of the
element, the markup for the documentElement itself is missing.
I will attach a test case demonstrating the problem.
The behaviour is the same with Mozilla 1.4a and Netscape 7.02 so this doesn't
seem to be a regression.
(Reporter)

Comment 1

15 years ago
Created attachment 119568 [details]
simple XML file to test serialization on
(Reporter)

Comment 2

15 years ago
Created attachment 119569 [details]
test case (documentElement is serialized and the result is shown with blue blackground, the markup for the documentElement is missing in all three examples)

*** This bug has been marked as a duplicate of 186554 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.