emhart-vic.com - "floating" popup window fails to open

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
15 years ago
3 years ago

People

(Reporter: Bob Dingman, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

In the page at http://www.emhart-vic.com/emhart/htm/default.asp a popup does not
appear when the mouse is positioned over the globe illustrated on the page.

Reproducible: Always

Steps to Reproduce:
1.Open page http://www.emhart-vic.com/emhart/htm/default.asp
2.Move mouse so that cursor is over globe (or until "javascript(0)" is indicated
in bottom bar of browser.

Actual Results:  
Nothing happened.

Expected Results:  
A position-dependent popup window/"text bubble" should have appeared.

The java Console shows:
Error:  document.all has no properties
at the above website and indicates the problem is on line 90.

The javascript in question appears to have been created automatically by
"Adobe(R) ImageStyler(TM) 1.0" and may be non-compliant with standards.

The popup window, however, did appear with Netscape 4.79 for Linux. It also
works with IE6/Win2k.

Comment 1

15 years ago
This isn't a bug in mozilla, but a bug in the site's javascript sniffer code...

  if(IsNN4 == true)
  {
    arrPop[0] = document.popup1;  
  }
  else
  {
    arrPop[0] = document.all.popup1;
  }

the abridged code snippet above shows the page only accounts for 2 browsers -
NN4's DOM & anything that follows IE's proprietary DOM.

-> Tech Evangelism
Assignee: rogerl → susiew
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US General
Ever confirmed: true
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → zach
Hardware: PC → All
Version: Trunk → unspecified

Comment 2

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: "floating" popup window fails to open → emhart-vic.com - "floating" popup window fails to open

Comment 3

4 years ago
URL is obsolete.
[closeme]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.