Scrolling artefacts/slow scrolling due to hidden divs

RESOLVED DUPLICATE of bug 198062

Status

()

Core
Layout: View Rendering
P2
normal
RESOLVED DUPLICATE of bug 198062
15 years ago
15 years ago

People

(Reporter: nick slussar, Assigned: roc)

Tracking

({perf, regression})

Trunk
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030405
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030405

if you go to the mozillanews page, mouse over the build bar and after that try
scrolling, there will be artefacts from some rectangular are on the page being a
bit late in scrolling after the rest of the page. scrolling is very slow too.

if you don't mouseover the buld bar, it will scroll much faster. sometimes with
artefacts, sometimes without.

Reproducible: Always

Steps to Reproduce:
0. turn on smoothscrolling 
1. http://www.mozillanews.org/
2. move mouse over the build bar 
   (gray bar on top of the page with words qw(Linux Mac9x OSX Win32 Sparc)
3. try scrolling after that

Actual Results:  
slow scrolling, artefacts

Expected Results:  
scrolling as usual, no artefacts

it happens even if you don't mouseover the build bar. it would be fast as usual,
and sometimes there will be artefacts, and sometimes everything will be fine.

Comment 1

15 years ago
I see this too in LInux 2003040308  
Also I get the same results w/o smoothscrolling.
The page is using visibility to change between hidden and visible.

Comment 2

15 years ago
I also see this with Build 2003040622 and Windows XP.
The artefacts are there regardless of whether smooth scroll is enabled or not.
Also scrolling is slow with and without smooth scrolling. So I remove the "with
smooth scrolling" part from the summary.

Somehow the hidden divs disturb the layout. I think Layout: View Rendering is
the right component for these kinds of bugs.
Assignee: kmcclusk → roc+moz
Status: UNCONFIRMED → NEW
Component: GFX → Layout: View Rendering
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: scrolling artefacts/slow scrolling (with smoothscroll enabled) → Scrolling artefacts/slow scrolling due to hidden divs

Comment 3

15 years ago
This regressed between the branching of 1.3 (20030222 - at least I deduce this
from testing with a build from further on the branch) and 2003031004. Anyone
have some builds from in between that time period to further narrow this down?

I agree that smoothscrolling isn't necessary for this; hovering the build bar is
necessary for me (win98) - easiest to see on the vote page:
http://www.mozillanews.org/vote_details.php3
Keywords: regression
Priority: -- → P2

Comment 4

15 years ago
*** Bug 203087 has been marked as a duplicate of this bug. ***
No longer blocks: 203439
Depends on: 203439

Updated

15 years ago
Keywords: perf

Comment 5

15 years ago
dupe

*** This bug has been marked as a duplicate of 198062 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.